aboutsummaryrefslogtreecommitdiff
path: root/net/ntp-stable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ntp-stable/Makefile')
-rw-r--r--net/ntp-stable/Makefile50
1 files changed, 0 insertions, 50 deletions
diff --git a/net/ntp-stable/Makefile b/net/ntp-stable/Makefile
deleted file mode 100644
index e4d55d4c36bc..000000000000
--- a/net/ntp-stable/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# New ports collection makefile for: ntp
-# Date created: Di 5 Mai 1998 21:31:03 CEST
-# Whom: andreas
-#
-# $FreeBSD$
-#
-
-PORTNAME= ntp
-PORTVERSION= 4.2.0
-PORTREVISION= 1
-CATEGORIES= net ipv6
-MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/ \
- http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ \
- ftp://ftp.archive.de.uu.net/pub/unix/ntp/ntp4/ \
- ftp://ftp.netlab.is.tsukuba.ac.jp/pub/network/ntp/ntp4/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
-
-MAINTAINER= cy@FreeBSD.org
-COMMENT= The Network Time Protocol Distribution
-
-LATEST_LINK= ${PORTNAME}
-
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-
-.if defined(ENABLE_RAWDCF)
-CONFIGURE_ARGS+= --enable-RAWDCF
-.endif
-
-.if defined(WITHOUT_SSL)
-CONFIGURE_ARGS+= --without-crypto
-PLIST_SUB+= SSL="@comment "
-.else
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --with-openssl-incdir=${OPENSSLINC} \
- --with-openssl-libdir=${OPENSSLLIB}
-PLIST_SUB+= SSL=""
-.endif
-
-post-install:
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/conf/* ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${FIND} ${WRKSRC}/html -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
- @cd ${WRKSRC}/html && ${FIND} . -print | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>