aboutsummaryrefslogtreecommitdiff
path: root/net/openggsn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openggsn/Makefile')
-rw-r--r--net/openggsn/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/net/openggsn/Makefile b/net/openggsn/Makefile
index 4ca675e028fd..ed00b69cb149 100644
--- a/net/openggsn/Makefile
+++ b/net/openggsn/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= openggsn
-PORTVERSION= 0.91
+PORTVERSION= 0.92
CATEGORIES= net
-MASTER_SITES= http://chaosophia.net/downloads/osmocom/${PORTNAME}/ \
- http://ns1.chaosophia.net/downloads/osmocom/${PORTNAME}/
+MASTER_SITES= http://git.osmocom.org/${PORTNAME}/snapshot/ \
+ http://chaosophia.net/downloads/osmocom/${PORTNAME}/
MAINTAINER= koue@chaosophia.net
COMMENT= Implementation of the Gateway GPRS Support Node element
@@ -12,8 +12,12 @@ COMMENT= Implementation of the Gateway GPRS Support Node element
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libosmocore.so:${PORTSDIR}/devel/libosmocore
+
GNU_CONFIGURE= yes
-USES= autoreconf gmake libtool
+USES= autoreconf gmake libtool pkgconfig
+
+USE_LDCONFIG= yes
post-patch:
${REINPLACE_CMD} -e 's|pkgconfigdir.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g' \