aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Google-SAML-Response
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-Google-SAML-Response')
-rw-r--r--net/p5-Google-SAML-Response/Makefile27
-rw-r--r--net/p5-Google-SAML-Response/distinfo3
-rw-r--r--net/p5-Google-SAML-Response/pkg-descr18
-rw-r--r--net/p5-Google-SAML-Response/pkg-plist8
4 files changed, 56 insertions, 0 deletions
diff --git a/net/p5-Google-SAML-Response/Makefile b/net/p5-Google-SAML-Response/Makefile
new file mode 100644
index 000000000000..658326e78158
--- /dev/null
+++ b/net/p5-Google-SAML-Response/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Google-SAML-Response
+# Date created: 2009-08-05
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Google-SAML-Response
+PORTVERSION= 0.07
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= SAML responses for Google\'s SSO implementation
+
+RUN_DEPENDS= p5-Crypt-OpenSSL-Bignum>0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
+ p5-Digest-SHA>0:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-Google-SAML-Request>0:${PORTSDIR}/net/p5-Google-SAML-Request \
+ p5-TimeDate>0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-XML-Canonical>0:${PORTSDIR}/textproc/p5-XML-Canonical
+
+PERL_CONFIGURE= yes
+
+MAN3= Google::SAML::Response.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Google-SAML-Response/distinfo b/net/p5-Google-SAML-Response/distinfo
new file mode 100644
index 000000000000..ffbd62fdce12
--- /dev/null
+++ b/net/p5-Google-SAML-Response/distinfo
@@ -0,0 +1,3 @@
+MD5 (Google-SAML-Response-0.07.tar.gz) = a5095cc74df4fcacda9de2ee19ca3687
+SHA256 (Google-SAML-Response-0.07.tar.gz) = 67af12b41cdd0a40455ba474f3bc12056cfa53fc99fd520ecf65ed19bfbfb485
+SIZE (Google-SAML-Response-0.07.tar.gz) = 18415
diff --git a/net/p5-Google-SAML-Response/pkg-descr b/net/p5-Google-SAML-Response/pkg-descr
new file mode 100644
index 000000000000..086a3925ee88
--- /dev/null
+++ b/net/p5-Google-SAML-Response/pkg-descr
@@ -0,0 +1,18 @@
+Google::SAML::Response can be used to generate a signed XML document
+that is needed for logging your users into Google using SSO.
+
+You have some sort of web application that can identify and
+authenticate users. You want users to be able to use some sort of
+Google service such as Google mail.
+
+When using SSO with your Google partner account, your users will send
+a request to a Google URL. If the user isn't already logged in to
+Google, Google will redirect him to a URL that you can define. Behind
+this URL, you need to have a script that authenticates users in your
+original framework and generates a SAML response for Google that you
+send back to the user whose browser will then submit it back to
+Google. If everything works, users will then be logged into their
+Google account and they don't even have to know their usernames or
+passwords.
+
+WWW: http://search.cpan.org/dist/Google-SAML-Response/
diff --git a/net/p5-Google-SAML-Response/pkg-plist b/net/p5-Google-SAML-Response/pkg-plist
new file mode 100644
index 000000000000..e1b2aba7aae3
--- /dev/null
+++ b/net/p5-Google-SAML-Response/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/SAML/Response/.packlist
+%%SITE_PERL%%/Google/SAML/Response.pm
+@dirrmtry %%SITE_PERL%%/Google/SAML
+@dirrmtry %%SITE_PERL%%/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/SAML/Response
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/SAML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google