aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-OpenID-Consumer
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-Net-OpenID-Consumer')
-rw-r--r--net/p5-Net-OpenID-Consumer/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/net/p5-Net-OpenID-Consumer/Makefile b/net/p5-Net-OpenID-Consumer/Makefile
index 2e431e8a9fe8..48a1d64d9a98 100644
--- a/net/p5-Net-OpenID-Consumer/Makefile
+++ b/net/p5-Net-OpenID-Consumer/Makefile
@@ -26,4 +26,16 @@ PERL_CONFIGURE= yes
MAN3= Net::OpenID::Association.3 Net::OpenID::ClaimedIdentity.3 \
Net::OpenID::Consumer.3 Net::OpenID::VerifiedIdentity.3
-.include <bsd.port.mk>
+.if defined(MAINTAINER_MODE)
+regression-test: build
+ cd ${WRKSRC} && ${MAKE} test
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>