aboutsummaryrefslogtreecommitdiff
path: root/net/quagga
diff options
context:
space:
mode:
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile1
-rw-r--r--net/quagga/files/patch-bgpd__bgp_attr.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 6502376250f1..c816e8ca2dcc 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,6 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.20
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
diff --git a/net/quagga/files/patch-bgpd__bgp_attr.c b/net/quagga/files/patch-bgpd__bgp_attr.c
new file mode 100644
index 000000000000..ed4b4eceb725
--- /dev/null
+++ b/net/quagga/files/patch-bgpd__bgp_attr.c
@@ -0,0 +1,10 @@
+--- ./bgpd/bgp_attr.c.orig 2011-10-18 10:12:39.000000000 -0400
++++ ./bgpd/bgp_attr.c 2011-10-18 10:13:01.000000000 -0400
+@@ -675,6 +675,7 @@
+ }
+
+ bgp_attr_unintern_sub (&tmp);
++ bgp_attr_extra_free (&tmp);
+ }
+
+ void