aboutsummaryrefslogtreecommitdiff
path: root/net/rtptools
diff options
context:
space:
mode:
Diffstat (limited to 'net/rtptools')
-rw-r--r--net/rtptools/Makefile30
-rw-r--r--net/rtptools/distinfo3
-rw-r--r--net/rtptools/files/patch-ab23
-rw-r--r--net/rtptools/files/patch-ac24
-rw-r--r--net/rtptools/files/patch-ad27
-rw-r--r--net/rtptools/pkg-descr15
6 files changed, 0 insertions, 122 deletions
diff --git a/net/rtptools/Makefile b/net/rtptools/Makefile
deleted file mode 100644
index ea02adc0d525..000000000000
--- a/net/rtptools/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# New ports collection makefile for: rtptools
-# Date created: 5 January 1998
-# Whom: fenner
-#
-# $FreeBSD$
-#
-
-PORTNAME= rtptools
-PORTVERSION= 1.18
-CATEGORIES= mbone
-MASTER_SITES= http://www.cs.columbia.edu/IRT/software/rtptools/download/
-
-MAINTAINER= tut@nhamon.com.ua
-COMMENT= A set of tools to record, playback and monitor RTPv2 data streams
-
-GNU_CONFIGURE= yes
-
-PLIST_FILES= bin/rtpdump bin/rtpplay bin/rtpsend bin/rtptrans
-DOCFILES= README ChangeLog.html rtptools.html
-PORTDOCS= ${DOCSFILES}
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${DOCFILES}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/net/rtptools/distinfo b/net/rtptools/distinfo
deleted file mode 100644
index 1d1d589b507d..000000000000
--- a/net/rtptools/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (rtptools-1.18.tar.gz) = 9a344c5a4fed2c4be0151cc03f043bb3
-SHA256 (rtptools-1.18.tar.gz) = 7fa16f71713ca16c5ce9cf5ccbd6796315f3402bdef9c7f7023ffac32c8e2ab0
-SIZE (rtptools-1.18.tar.gz) = 119272
diff --git a/net/rtptools/files/patch-ab b/net/rtptools/files/patch-ab
deleted file mode 100644
index c1d142b4a914..000000000000
--- a/net/rtptools/files/patch-ab
+++ /dev/null
@@ -1,23 +0,0 @@
---- rtp.h.orig Thu Mar 9 07:35:26 2000
-+++ rtp.h Sat Apr 21 21:52:49 2001
-@@ -110,13 +110,18 @@
- #define RTCP_VALID_MASK (0xc000 | 0x2000 | 0xfe)
- #define RTCP_VALID_VALUE ((RTP_VERSION << 14) | RTCP_SR)
-
-+#define RTCP_FRACTION(x) (((x) >> 24) & 0xFF)
-+#define RTCP_LOST(x) ((((x) & 0xFFFFFF) < 0x800000) ? \
-+ ((x) & 0xFFFFFF) \
-+ : (((x) & 0xFFFFFF) - 0x1000000))
-+
- /*
- * Reception report block
- */
- typedef struct {
- u_int32 ssrc; /* data source being reported */
-- unsigned int fraction:8; /* fraction lost since last SR/RR */
-- int lost:24; /* cumul. no. pkts lost (signed!) */
-+ u_int32 fraclost; /* fraction lost since last SR/RR and */
-+ /* cumul. no. pkts lost (signed!) */
- u_int32 last_seq; /* extended last seq. no. received */
- u_int32 jitter; /* interarrival jitter */
- u_int32 lsr; /* last SR packet from this source */
diff --git a/net/rtptools/files/patch-ac b/net/rtptools/files/patch-ac
deleted file mode 100644
index 28056951ca69..000000000000
--- a/net/rtptools/files/patch-ac
+++ /dev/null
@@ -1,24 +0,0 @@
---- rtpdump.c.orig Sat Apr 7 08:02:13 2001
-+++ rtpdump.c Sat Apr 21 21:54:10 2001
-@@ -429,8 +429,8 @@
- for (i = 0; i < r->common.count; i++) {
- fprintf(out, " (ssrc=0x%lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu )\n",
- (unsigned long)ntohl(r->r.sr.rr[i].ssrc),
-- r->r.sr.rr[i].fraction / 256.,
-- (unsigned long)ntohl(r->r.sr.rr[i].lost), /* XXX I'm pretty sure this is wrong */
-+ RTCP_FRACTION(ntohl(r->r.sr.rr[i].fraclost)) / 256.,
-+ RTCP_LOST(ntohl(r->r.sr.rr[i].fraclost)),
- (unsigned long)ntohl(r->r.sr.rr[i].last_seq),
- (unsigned long)ntohl(r->r.sr.rr[i].jitter),
- (unsigned long)ntohl(r->r.sr.rr[i].lsr),
-@@ -446,8 +446,8 @@
- for (i = 0; i < r->common.count; i++) {
- fprintf(out, " (ssrc=0x%lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu )\n",
- (unsigned long)ntohl(r->r.rr.rr[i].ssrc),
-- r->r.rr.rr[i].fraction / 256.,
-- (unsigned long)ntohl(r->r.rr.rr[i].lost),
-+ RTCP_FRACTION(ntohl(r->r.rr.rr[i].fraclost)) / 256.,
-+ RTCP_LOST(ntohl(r->r.rr.rr[i].fraclost)),
- (unsigned long)ntohl(r->r.rr.rr[i].last_seq),
- (unsigned long)ntohl(r->r.rr.rr[i].jitter),
- (unsigned long)ntohl(r->r.rr.rr[i].lsr),
diff --git a/net/rtptools/files/patch-ad b/net/rtptools/files/patch-ad
deleted file mode 100644
index 130804a6b732..000000000000
--- a/net/rtptools/files/patch-ad
+++ /dev/null
@@ -1,27 +0,0 @@
-
-$FreeBSD$
-
---- rtpsend.c.orig Tue Sep 10 13:24:10 2002
-+++ rtpsend.c Sat Aug 16 08:58:12 2003
-@@ -353,9 +353,9 @@
- if (strcmp(n->type, "ssrc") == 0)
- rr->ssrc = htonl(n->num);
- else if (strcmp(n->type, "fraction") == 0)
-- rr->fraction = (n->num)*256;
-- else if (strcmp(n->type, "lost") == 0) /* PP: alignment OK? */
-- rr->lost = htonl(n->num);
-+ rr->fraclost = htonl((ntohl(rr->fraclost) & 0x00ffffff) | ((n->num)*256 << 24));
-+ else if (strcmp(n->type, "lost") == 0)
-+ rr->fraclost = htonl((ntohl(rr->fraclost) & 0xff000000) | n->num);
- else if (strcmp(n->type, "last_seq") == 0)
- rr->last_seq = htonl(n->num);
- else if (strcmp(n->type, "jit") == 0)
-@@ -919,6 +919,8 @@
- local = (struct in_addr *)host->h_addr_list[0];
- sin.sin_addr = *local;
- }
-+ } else {
-+ usage(argv[0]);
- }
-
- /* create/connect sockets */
diff --git a/net/rtptools/pkg-descr b/net/rtptools/pkg-descr
deleted file mode 100644
index be50ee27bf15..000000000000
--- a/net/rtptools/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-The rtptools distribution consists of a number of small applications that
-can be used for processing RTP data.
-
-rtpplay
- play back RTP sessions recorded by rtpdump
-rtpsend
- generate RTP packets from textual description, generated by hand or
- rtpdump
-rtpdump
- parse and print RTP packets, generating output files suitable for
- rtpplay and rtpsend
-rtptrans
- RTP translator between unicast and multicast networks
-
-WWW: http://www.cs.columbia.edu/irt/software/rtptools/