aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-activestorage52
diff options
context:
space:
mode:
Diffstat (limited to 'net/rubygem-activestorage52')
-rw-r--r--net/rubygem-activestorage52/Makefile27
-rw-r--r--net/rubygem-activestorage52/distinfo3
-rw-r--r--net/rubygem-activestorage52/pkg-descr13
3 files changed, 43 insertions, 0 deletions
diff --git a/net/rubygem-activestorage52/Makefile b/net/rubygem-activestorage52/Makefile
new file mode 100644
index 000000000000..b5f904a411f9
--- /dev/null
+++ b/net/rubygem-activestorage52/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= activestorage
+PORTVERSION= 5.2.3
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 52
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Attach cloud and local files in Rails applications
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack52>=${PORTVERSION}:www/rubygem-actionpack52 \
+ rubygem-activerecord52>=${PORTVERSION}:databases/rubygem-activerecord52 \
+ rubygem-marcel>=0.3.1:devel/rubygem-marcel
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^5\.2\.
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-activestorage52/distinfo b/net/rubygem-activestorage52/distinfo
new file mode 100644
index 000000000000..b478f3347327
--- /dev/null
+++ b/net/rubygem-activestorage52/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1566756751
+SHA256 (rubygem/activestorage-5.2.3.gem) = 53eafa1e02a3c99367ffdf81e6f0f337a7d456e1a85e14cf182e702c6f343a12
+SIZE (rubygem/activestorage-5.2.3.gem) = 44032
diff --git a/net/rubygem-activestorage52/pkg-descr b/net/rubygem-activestorage52/pkg-descr
new file mode 100644
index 000000000000..49e1e9d876c4
--- /dev/null
+++ b/net/rubygem-activestorage52/pkg-descr
@@ -0,0 +1,13 @@
+Active Storage makes it simple to upload and reference files in cloud services
+like Amazon S3, Google Cloud Storage, or Microsoft Azure Storage, and attach
+those files to Active Records. Supports having one main service and mirrors in
+other services for redundancy. It also provides a disk service for testing or
+local deployments, but the focus is on cloud storage.
+
+Files can be uploaded from the server to the cloud or directly from the client
+to the cloud.
+
+Image files can furthermore be transformed using on-demand variants for quality,
+aspect ratio, size, or any other MiniMagick supported transformation.
+
+WWW: https://rubyonrails.org/