aboutsummaryrefslogtreecommitdiff
path: root/net/service-discovery-applet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/service-discovery-applet/Makefile')
-rw-r--r--net/service-discovery-applet/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/net/service-discovery-applet/Makefile b/net/service-discovery-applet/Makefile
index 7614f7529b6b..c64157694c3f 100644
--- a/net/service-discovery-applet/Makefile
+++ b/net/service-discovery-applet/Makefile
@@ -3,21 +3,22 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom$
+# $MCom: ports/net/service-discovery-applet/Makefile,v 1.3 2006/10/11 05:53:39 marcus Exp $
#
PORTNAME= service-discovery-applet
PORTVERSION= 0.4.3
+PORTREVISION= 1
CATEGORIES= net dns gnome
MASTER_SITES= http://0pointer.de/~sebest/
MAINTAINER= gnome@FreeBSD.org
COMMENT= A GNOME applet that shows available network services using mDNS
-BUILD_DEPENDS= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/avahi/__init__.py:${PORTSDIR}/net/py-avahi
-RUN_DEPENDS= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/avahi/__init__.py:${PORTSDIR}/net/py-avahi
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/avahi/__init__.py:${PORTSDIR}/net/py-avahi
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/avahi/__init__.py:${PORTSDIR}/net/py-avahi
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GETTEXT= yes
USE_PYTHON= yes
USE_GNOME= gnomehack gnomeprefix intlhack pygnomedesktop
@@ -31,10 +32,10 @@ GCONF_SCHEMAS= service-discovery-applet.schemas
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/plugins/gconfterminal.py.in
+ ${WRKSRC}/plugins/gconfterminal.py.in
post-install:
- @${X11BASE}/bin/gtk-update-icon-cache -f -q --ignore-theme-index \
+ @${LOCALBASE}/bin/gtk-update-icon-cache -f -q --ignore-theme-index \
${PREFIX}/share/gnome/service-discovery-applet/icons
.include <bsd.port.mk>