aboutsummaryrefslogtreecommitdiff
path: root/net/silc-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/silc-server/Makefile')
-rw-r--r--net/silc-server/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/net/silc-server/Makefile b/net/silc-server/Makefile
index a2f1b486dd01..86d863fcec17 100644
--- a/net/silc-server/Makefile
+++ b/net/silc-server/Makefile
@@ -9,7 +9,17 @@ PORTNAME= silc
PORTVERSION= 0.6.2
CATEGORIES= net security
MASTER_SITES= http://www.silcnet.org/download/ \
- ftp://ftp.silcnet.org/pub/silc/
+ ftp://ftp.silcnet.org/pub/silc/ \
+ http://ftp.silcnet.org/ \
+ http://munitions.vipul.net/software/mirrors/silc/ \
+ ftp://ftp.wiretapped.net/pub/security/network-security/silc/ \
+ http://www.au.silcnet.org/download/ \
+ ftp://ftp.au.silcnet.org/pub/silcnet/ \
+ http://www.planetmirror.com/pub/silcnet/ \
+ http://the.wiretapped.net/security/network-security/silc/ \
+ ftp://ftp.wiretapped.net/pub/security/network-security/silc/ \
+ http://www.no.silcnet.org/download/ \
+ ftp://ftp.no.silcnet.org/pub/silc/
PKGNAMESUFFIX= -server
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
@@ -26,6 +36,7 @@ CONFIGURE_ARGS= --with-silcd-config-file=${PREFIX}/etc/${PORTNAME}/silcd.conf \
--with-simdir=libexec/${PORTNAME}/modules
INSTALLS_SHLIB= yes
PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
+PKGDEINSTALL= ${PKGINSTALL}
INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
@@ -57,6 +68,10 @@ post-patch:
@${PERL} -pi -e 's/-O2//' ${WRKSRC}/${CONFIGURE_SCRIPT}
.endif
+post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
+ ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"