aboutsummaryrefslogtreecommitdiff
path: root/net/uplog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/uplog/Makefile')
-rw-r--r--net/uplog/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/uplog/Makefile b/net/uplog/Makefile
new file mode 100644
index 000000000000..9d10f5d1fb7e
--- /dev/null
+++ b/net/uplog/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: uplog
+# Date created: 16.06.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uplog
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= http://www.nerdlabs.org/downloads/${PORTNAME}/
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= UDP-based ping programm
+
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ ${REINPLACE_CMD} -e \
+ 's|#include <malloc.h>||g' \
+ ${WRKSRC}/${PORTNAME}.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>