aboutsummaryrefslogtreecommitdiff
path: root/net/whois
diff options
context:
space:
mode:
Diffstat (limited to 'net/whois')
-rw-r--r--net/whois/Makefile5
-rw-r--r--net/whois/files/patch-aa4
2 files changed, 6 insertions, 3 deletions
diff --git a/net/whois/Makefile b/net/whois/Makefile
index 4ee5ee9593b5..73a9e7e668f1 100644
--- a/net/whois/Makefile
+++ b/net/whois/Makefile
@@ -25,8 +25,11 @@ USE_GMAKE= yes
USE_GETOPT_LONG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
+
post-patch:
- @${REINPLACE_CMD} -e "s|prefix\=/usr/local|prefix\=${PREFIX}|g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s|prefix\=/usr/local|prefix\=${PREFIX}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s|/usr/share|${PREFIX}/share|g" ${WRKSRC}/po/Makefile
.include <bsd.port.mk>
diff --git a/net/whois/files/patch-aa b/net/whois/files/patch-aa
index 2ff7c45811b6..dc97e3fd4770 100644
--- a/net/whois/files/patch-aa
+++ b/net/whois/files/patch-aa
@@ -14,8 +14,8 @@
#LDFLAGS=-lintl
# FreeBSD
-! LDFLAGS=-L/usr/local/lib -lgnugetopt -lintl
-! CFLAGS=-I/usr/local/include
+! LDFLAGS+=-L%%LOCALBASE%%/lib -lintl
+! CFLAGS+=-I%%LOCALBASE%%/include
# OS/2 EMX
#LDFLAGS=-lsocket -Zexe -Dstrncasecmp=strnicmp