aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/grilo-plugins/Makefile2
-rw-r--r--net/knemo-kde4/Makefile2
-rw-r--r--net/kwooty/Makefile2
-rw-r--r--net/libzapojit/Makefile6
-rw-r--r--net/liferea/Makefile4
-rw-r--r--net/minidlna/Makefile10
-rw-r--r--net/remmina-plugin-i18n/Makefile2
-rw-r--r--net/remmina-plugins/bsd.plugin.mk2
8 files changed, 14 insertions, 16 deletions
diff --git a/net/grilo-plugins/Makefile b/net/grilo-plugins/Makefile
index 683c5c03481f..7288723dbd4b 100644
--- a/net/grilo-plugins/Makefile
+++ b/net/grilo-plugins/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libgrilo-0.2.so:${PORTSDIR}/net/grilo \
libavahi-gobject.so:${PORTSDIR}/net/avahi-app \
libgdata.so:${PORTSDIR}/devel/libgdata
-USES= gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
USE_GNOME= glib20 intlhack libxml2
GNU_CONFIGURE= yes
diff --git a/net/knemo-kde4/Makefile b/net/knemo-kde4/Makefile
index 27002b62e13b..b442c0b3696e 100644
--- a/net/knemo-kde4/Makefile
+++ b/net/knemo-kde4/Makefile
@@ -10,7 +10,7 @@ DISTNAME= 12956-${PORTNAME}-${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= KDE network monitor
-USES= cmake tar:bzip2
+USES= cmake gettext tar:bzip2
USE_QT4= qmake_build moc_build uic_build rcc_build
USE_KDE4= kdeprefix kdelibs workspace automoc4
diff --git a/net/kwooty/Makefile b/net/kwooty/Makefile
index c0ce31322838..49f984ab660c 100644
--- a/net/kwooty/Makefile
+++ b/net/kwooty/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/unrar:${PORTSDIR}/archivers/unrar \
USE_KDE4= kdelibs kdehier kdeprefix automoc4 workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
-USES= cmake
+USES= cmake gettext
USE_LDCONFIG= yes
post-patch:
diff --git a/net/libzapojit/Makefile b/net/libzapojit/Makefile
index b059cd2e9037..0f491b7faf2b 100644
--- a/net/libzapojit/Makefile
+++ b/net/libzapojit/Makefile
@@ -17,12 +17,12 @@ LIB_DEPENDS= libgoa-1.0.so:${PORTSDIR}/net/gnome-online-accounts \
libjson-glib-1.0.so:${PORTSDIR}/devel/json-glib \
librest-0.7.so:${PORTSDIR}/devel/librest
-USES= gmake libtool pathfix pkgconfig tar:xz
-USE_GNOME= gnomeprefix intlhack
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gnomeprefix intltool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
.include <bsd.port.mk>
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 3bd87ab96e26..26323ecf9a09 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -19,13 +19,13 @@ LIB_DEPENDS= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3 \
libjson-glib-1.0.so:${PORTSDIR}/devel/json-glib
RUN_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
-USES= desktop-file-utils gmake libtool pathfix pkgconfig \
+USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
tar:bzip2
USE_GNOME= gnomeprefix gtk30 introspection:build libxslt:build libxml2
USE_SQLITE= 3
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --disable-libnotify --disable-libindicate
diff --git a/net/minidlna/Makefile b/net/minidlna/Makefile
index b0d9e5b01970..c9a53dc0b8c4 100644
--- a/net/minidlna/Makefile
+++ b/net/minidlna/Makefile
@@ -22,11 +22,9 @@ LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-db-path=/var/db/minidlna \
--with-os-url="http://www.FreeBSD.org"
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USES= iconv
-USE_AUTOTOOLS= autoconf aclocal automake
-AUTOMAKE_ARGS= --add-missing
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+USES= autoreconf gettext-tools iconv
PKGMESSAGE= ${WRKSRC}/pkg-message
SUB_FILES+= pkg-message
@@ -42,7 +40,7 @@ OPTIONS_SUB= yes
DEBUG_CFLAGS= -DDEBUG
KQUEUE_DESC= Experimental patch for automatic rescan using kqueue(2)
-NLS_USES= gettext
+NLS_USES= gettext-runtime
.include <bsd.port.options.mk>
diff --git a/net/remmina-plugin-i18n/Makefile b/net/remmina-plugin-i18n/Makefile
index d459aadde2cc..a818d3470e70 100644
--- a/net/remmina-plugin-i18n/Makefile
+++ b/net/remmina-plugin-i18n/Makefile
@@ -7,6 +7,6 @@ COMMENT= Localized messages for Remmina plugins
MASTERDIR= ${.CURDIR}/../remmina-plugins
-USES+= gettext
+USES= gettext-tools
.include "${MASTERDIR}/Makefile"
diff --git a/net/remmina-plugins/bsd.plugin.mk b/net/remmina-plugins/bsd.plugin.mk
index c88328931500..45fbc0247f22 100644
--- a/net/remmina-plugins/bsd.plugin.mk
+++ b/net/remmina-plugins/bsd.plugin.mk
@@ -8,7 +8,7 @@ LICENSE= GPLv2
BUILD_DEPENDS+= remmina>=${PORTVERSION}:${PORTSDIR}/net/remmina
RUN_DEPENDS+= remmina>=${PORTVERSION}:${PORTSDIR}/net/remmina
-USES= cmake gmake pkgconfig
+USES+= cmake gmake pkgconfig
USE_GNOME= atk desktopfileutils gdkpixbuf2 glib20 gtk20 pango
INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}