aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ssmping/Makefile34
-rw-r--r--net/ssmping/distinfo3
-rw-r--r--net/ssmping/files/patch-makefile32
-rw-r--r--net/ssmping/pkg-descr6
5 files changed, 76 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5527e6a26b6e..babb2443d9b3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -737,6 +737,7 @@
SUBDIR += ssldump
SUBDIR += ssltunnel-client
SUBDIR += ssltunnel-server
+ SUBDIR += ssmping
SUBDIR += stone
SUBDIR += straw
SUBDIR += stund
diff --git a/net/ssmping/Makefile b/net/ssmping/Makefile
new file mode 100644
index 000000000000..c558c2d825c9
--- /dev/null
+++ b/net/ssmping/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ssmping
+# Date created: 20 August 2006
+# Whom: dikshie@lapi.itb.ac.id
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssmping
+PORTVERSION= 0.9
+CATEGORIES= net
+MASTER_SITES= http://www.venaas.no/multicast/ssmping/
+
+MAINTAINER= dikshie@lapi.itb.ac.id
+COMMENT= Ping for ASM and SSM
+
+MAN1= ssmping.1 \
+ asmping.1 \
+ mcfirst.1
+
+PLIST_FILES= bin/ssmping \
+ bin/asmping \
+ bin/mcfirst \
+ sbin/ssmpingd
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ssmping ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/asmping ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mcfirst ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ssmpingd ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/ssmping.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/asmping.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/mcfirst.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/ssmping/distinfo b/net/ssmping/distinfo
new file mode 100644
index 000000000000..08f734a09ffe
--- /dev/null
+++ b/net/ssmping/distinfo
@@ -0,0 +1,3 @@
+MD5 (ssmping-0.9.tar.gz) = 08350cba127b63ed7cdd662e7a0b37a1
+SHA256 (ssmping-0.9.tar.gz) = e9cde8a131800038b7e88d5a335fa08cf40d33f5b7db9bc5228a68c639f6adb9
+SIZE (ssmping-0.9.tar.gz) = 16464
diff --git a/net/ssmping/files/patch-makefile b/net/ssmping/files/patch-makefile
new file mode 100644
index 000000000000..703decacec74
--- /dev/null
+++ b/net/ssmping/files/patch-makefile
@@ -0,0 +1,32 @@
+--- Makefile Sun Jun 4 17:16:04 2006
++++ Makefile-bsd Sun Jun 4 17:16:04 2006
+@@ -2,12 +2,19 @@
+
+ all: ssmping asmping ssmpingd mcfirst
+
+-OBJ = ssmpngcl.o ssmpingc.o
++OBJ = ssmpngcl.o ssmpingc.o joinch.o joingrp.o
++
++ssmping: $(OBJ)
++ $(CC) $(CFLAGS) $(OBJ) -o ssmping ssmping.c
++
++asmping: $(OBJ)
++ $(CC) $(CFLAGS) $(OBJ) -o asmping asmping.c
+
+-ssmping: $(OBJ) joinch.o
+-asmping: $(OBJ) joingrp.o
+-mcfirst: $(OBJ) joinch.o joingrp.o
+ ssmpingd: $(OBJ)
++ $(CC) $(CFLAGS) $(OBJ) -o ssmpingd ssmpingd.c
++
++mcfirst: $(OBJ)
++ $(CC) $(CFLAGS) $(OBJ) -o mcfirst mcfirst.c
+
+ install: ssmping asmping ssmpingd mcfirst
+ install -D ssmping $(DESTDIR)$(PREFIX)/bin/ssmping
+@@ -19,4 +26,4 @@
+ install -D mcfirst.1 $(DESTDIR)$(PREFIX)/man/man1/mcfirst.1
+
+ clean:
+- rm -f $(OBJ) joinch.o joingrp.o ssmping asmping ssmpingd mcfirst
++ rm -f $(OBJ) ssmping asmping ssmpingd mcfirst
diff --git a/net/ssmping/pkg-descr b/net/ssmping/pkg-descr
new file mode 100644
index 000000000000..ab101a933f5c
--- /dev/null
+++ b/net/ssmping/pkg-descr
@@ -0,0 +1,6 @@
+ssmping is a tool for checking whether a host can receive SSM from
+another. If a host runst ssmpingd, users on other hosts can check
+that they receive from this host by running the ssmping tool.
+asmping is similar to ssmping, but checks for ASM rather than SSM.
+
+WWW: http://www.venaas.no/multicast/ssmping/