aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/xmlrpc-c-devel/Makefile6
-rw-r--r--net/xmlrpc-c-devel/files/patch-src-XmlRpcCpp.h12
-rw-r--r--net/xmlrpc-c/Makefile6
-rw-r--r--net/xmlrpc-c/files/patch-src-XmlRpcCpp.h12
4 files changed, 30 insertions, 6 deletions
diff --git a/net/xmlrpc-c-devel/Makefile b/net/xmlrpc-c-devel/Makefile
index 618b47f09036..b7edb2f00c30 100644
--- a/net/xmlrpc-c-devel/Makefile
+++ b/net/xmlrpc-c-devel/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Frontier/Client.pm:${PORTSDIR}/net/p5-Frontier-RPC
+USE_REINPLACE= yes
USE_LIBTOOL= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
@@ -26,10 +27,9 @@ MAN1= meerkat-app-list.1 xml-rpc-api2cpp.1 xmlrpc-c-config.1 \
MAN7= xmlrpc-c.7
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/lib/abyss/src/data.c \
- ${WRKSRC}/tools/turbocharger/mod_gzip.c \
- ${WRKSRC}/tools/turbocharger/mod_gzip.c
+ ${WRKSRC}/tools/turbocharger/mod_gzip.c
post-install:
@${RM} -f ${PREFIX}/lib/*.la
diff --git a/net/xmlrpc-c-devel/files/patch-src-XmlRpcCpp.h b/net/xmlrpc-c-devel/files/patch-src-XmlRpcCpp.h
new file mode 100644
index 000000000000..21e18d881ebc
--- /dev/null
+++ b/net/xmlrpc-c-devel/files/patch-src-XmlRpcCpp.h
@@ -0,0 +1,12 @@
+--- src/XmlRpcCpp.h.orig Thu Nov 14 09:17:52 2002
++++ src/XmlRpcCpp.h Thu Nov 14 09:18:17 2002
+@@ -45,8 +45,8 @@
+ // work with our version of g++). So this header name is technically wrong.
+ // Tell me what your compiler does; I can provide some autoconf magic to the
+ // Right Thing on most platforms.
++using namespace std;
+ #include <string>
+-// using namespace std;
+
+ #include <xmlrpc.h>
+ #include <xmlrpc_client.h>
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
index 618b47f09036..b7edb2f00c30 100644
--- a/net/xmlrpc-c/Makefile
+++ b/net/xmlrpc-c/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Frontier/Client.pm:${PORTSDIR}/net/p5-Frontier-RPC
+USE_REINPLACE= yes
USE_LIBTOOL= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
@@ -26,10 +27,9 @@ MAN1= meerkat-app-list.1 xml-rpc-api2cpp.1 xmlrpc-c-config.1 \
MAN7= xmlrpc-c.7
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/lib/abyss/src/data.c \
- ${WRKSRC}/tools/turbocharger/mod_gzip.c \
- ${WRKSRC}/tools/turbocharger/mod_gzip.c
+ ${WRKSRC}/tools/turbocharger/mod_gzip.c
post-install:
@${RM} -f ${PREFIX}/lib/*.la
diff --git a/net/xmlrpc-c/files/patch-src-XmlRpcCpp.h b/net/xmlrpc-c/files/patch-src-XmlRpcCpp.h
new file mode 100644
index 000000000000..21e18d881ebc
--- /dev/null
+++ b/net/xmlrpc-c/files/patch-src-XmlRpcCpp.h
@@ -0,0 +1,12 @@
+--- src/XmlRpcCpp.h.orig Thu Nov 14 09:17:52 2002
++++ src/XmlRpcCpp.h Thu Nov 14 09:18:17 2002
+@@ -45,8 +45,8 @@
+ // work with our version of g++). So this header name is technically wrong.
+ // Tell me what your compiler does; I can provide some autoconf magic to the
+ // Right Thing on most platforms.
++using namespace std;
+ #include <string>
+-// using namespace std;
+
+ #include <xmlrpc.h>
+ #include <xmlrpc_client.h>