aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/p5-Geo-IP/Makefile24
-rw-r--r--net/p5-Geo-IP/distinfo1
-rw-r--r--net/p5-Geo-IP/pkg-comment1
-rw-r--r--net/p5-Geo-IP/pkg-descr17
-rw-r--r--net/p5-Geo-IP/pkg-plist9
5 files changed, 52 insertions, 0 deletions
diff --git a/net/p5-Geo-IP/Makefile b/net/p5-Geo-IP/Makefile
new file mode 100644
index 000000000000..a4cab041a3ad
--- /dev/null
+++ b/net/p5-Geo-IP/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Geo-IP
+# Date created: 10 August 2002
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-IP
+PORTVERSION= 0.26
+CATEGORIES= misc
+MASTER_SITES= http://maxmind.com/download/geoip/api/perl/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@FreeBSD.org
+
+LIB_DEPENDS= GeoIP.1:${PORTSDIR}/misc/GeoIP
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= LIBS='-L${PREFIX}/lib' INC='-I${PREFIX}/include'
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Geo::Mirror.3 Geo::IP.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Geo-IP/distinfo b/net/p5-Geo-IP/distinfo
new file mode 100644
index 000000000000..a208d2fa2f4c
--- /dev/null
+++ b/net/p5-Geo-IP/distinfo
@@ -0,0 +1 @@
+MD5 (Geo-IP-0.26.tar.gz) = 233ee112eec0139e952978c9780bc209
diff --git a/net/p5-Geo-IP/pkg-comment b/net/p5-Geo-IP/pkg-comment
new file mode 100644
index 000000000000..c0ffc2f8436a
--- /dev/null
+++ b/net/p5-Geo-IP/pkg-comment
@@ -0,0 +1 @@
+Gets country name by IP or hostname
diff --git a/net/p5-Geo-IP/pkg-descr b/net/p5-Geo-IP/pkg-descr
new file mode 100644
index 000000000000..2319f3c4ef94
--- /dev/null
+++ b/net/p5-Geo-IP/pkg-descr
@@ -0,0 +1,17 @@
+This module a simple file-based database. This database simply contains
+IP blocks as keys, and countries as values. The data contains all
+public IP addresses and should be more
+complete and accurate than reverse DNS lookups.
+
+This module can be used to automatically select the geographically closest
+mirror, or to analyze your web server logs to determine the countries of
+your visiters.
+
+To install, see the INSTALL file.
+
+Copyright (c) 2002, MaxMind.com
+
+All rights reserved. This package is free software; you can redistribute it
+and/or modify it under the same terms as Perl itself.
+
+WWW: http://maxmind.com/geoip/api/perl.shtml
diff --git a/net/p5-Geo-IP/pkg-plist b/net/p5-Geo-IP/pkg-plist
new file mode 100644
index 000000000000..2e669d5a5b33
--- /dev/null
+++ b/net/p5-Geo-IP/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Geo/IP.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Geo/Mirror.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Geo/IP/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Geo/IP/IP.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Geo/IP/IP.so
+lib/perllocal.pod
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Geo/IP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Geo
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Geo