aboutsummaryrefslogtreecommitdiff
path: root/news/inn-current/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/inn-current/Makefile')
-rw-r--r--news/inn-current/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/news/inn-current/Makefile b/news/inn-current/Makefile
index c299824f0996..7aa24962f4fd 100644
--- a/news/inn-current/Makefile
+++ b/news/inn-current/Makefile
@@ -45,7 +45,8 @@ CONFIGURE_ARGS+= --mandir=${PREFIX}/man \
--with-log-dir=${INN_NEWSLOG} \
--with-perl \
--with-tmp-dir=${INN_NEWSSPOOL}/tmp \
- --with-openssl=${OPENSSLBASE}
+ --with-openssl=${OPENSSLBASE} \
+ --with-etc-dir=${ETC_DIR}
.if !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
@@ -129,6 +130,14 @@ MAN8= actsync.8 actsyncd.8 archive.8 auth_smb.8 batcher.8 buffchan.8 \
.include <bsd.port.pre.mk>
+.if defined(WITH_STANDARD_ETC)
+ETC_DIR= ${PREFIX}/etc/inn
+PLIST_SUB+= ETCDIR=etc/inn
+.else
+ETC_DIR= ${PREFIX}/news/etc
+PLIST_SUB+= ETCDIR=news/etc
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's!/usr/local!${LOCALBASE}!' ${WRKSRC}/configure
.if defined(WITH_TCL)
@@ -154,7 +163,7 @@ post-install:
s+!!PREFIX!!+${PREFIX}+g && ${CHMOD} +x ${PREFIX}/etc/rc.d/innd.sh
@${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
@${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
- @PKG_PREFIX=${PKG_PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF
+ @PKG_PREFIX=${PKG_PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
cd ${PREFIX}/news/db ; \