aboutsummaryrefslogtreecommitdiff
path: root/news/newsx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/newsx/Makefile')
-rw-r--r--news/newsx/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/news/newsx/Makefile b/news/newsx/Makefile
index 511c73705e41..aa4d63e35a4a 100644
--- a/news/newsx/Makefile
+++ b/news/newsx/Makefile
@@ -10,12 +10,14 @@ PORTVERSION= 1.4
CATEGORIES= news
MASTER_SITES= ftp://ftp.kvaleberg.com/pub/
-MAINTAINER= tthomas@mail.dotcom.fr
+MAINTAINER= thierry@thomas.as
-BUILD_DEPENDS= ${LOCALBASE}/news/lib/libinn.a:${PORTSDIR}/news/inn:${hdr_dir}
+BUILD_DEPENDS= ${LOCALBASE}/news/lib/libinn.a:${PORTSDIR}/news/inn
hdr_dir= ${LOCALBASE}/news/include
+DOCS= AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
+
post-extract:
@${ECHO} "*********************************************************"
@${ECHO} "If this step fails, then you probably don't have made inn"
@@ -42,6 +44,15 @@ post-configure:
@${PERL} -pi -e "s:^LIBS = :LIBS = -L${LOCALBASE}/news/lib -linn:g" \
${WRKSRC}/test/Makefile
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+ @${ECHO} "Documentation installed in ${DOCSDIR}."
+.endif
+
#GNU_CONFIGURE= yes
USE_AUTOCONF= yes