aboutsummaryrefslogtreecommitdiff
path: root/news/pan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/pan/Makefile')
-rw-r--r--news/pan/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 3d6d6853c001..62fea758e280 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pan
-PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTVERSION= 0.10.0
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/${PORTVERSION}/
@@ -19,13 +18,14 @@ USE_GMAKE= yes
USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib -lgnuregex -lcompat"
CONFIGURE_ARGS= --enable-html
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'