aboutsummaryrefslogtreecommitdiff
path: root/palm/gnomepilot-conduits2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'palm/gnomepilot-conduits2/Makefile')
-rw-r--r--palm/gnomepilot-conduits2/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/palm/gnomepilot-conduits2/Makefile b/palm/gnomepilot-conduits2/Makefile
index f83c7c1dbf97..9511b3a735ff 100644
--- a/palm/gnomepilot-conduits2/Makefile
+++ b/palm/gnomepilot-conduits2/Makefile
@@ -31,4 +31,11 @@ CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" GLIB_CONFIG="${GLIB_CONFIG}" \
CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/pilot/include" \
LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/pilot/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>