aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/genplist/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/genplist/Makefile')
-rw-r--r--ports-mgmt/genplist/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/ports-mgmt/genplist/Makefile b/ports-mgmt/genplist/Makefile
index 640d35b6597c..0660c60cf5c3 100644
--- a/ports-mgmt/genplist/Makefile
+++ b/ports-mgmt/genplist/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: genplist
# Date created: 2007-04-19
-# Whom: Jason Bacon bacon@smithers.neuro.mcw.edu
+# Whom: Jason Bacon <jwbacon@tds.net>
#
# $FreeBSD$
#
PORTNAME= genplist
-PORTVERSION= 0.3
+PORTVERSION= 0.4
CATEGORIES= ports-mgmt
MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/ \
http://jbacon.dyndns.org/~bacon/Ports/distfiles/
@@ -24,4 +24,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/genplist ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/genplist.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+post-patch:
+ ${REINPLACE_CMD} 's|/etc/mtree|$${PORTSDIR=/usr/ports}/Templates|' ${WRKSRC}/genplist
+.include <bsd.port.post.mk>