aboutsummaryrefslogtreecommitdiff
path: root/print/cups-pstoraster/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/cups-pstoraster/Makefile')
-rw-r--r--print/cups-pstoraster/Makefile41
1 files changed, 16 insertions, 25 deletions
diff --git a/print/cups-pstoraster/Makefile b/print/cups-pstoraster/Makefile
index 4c674963439c..b0e113dea78d 100644
--- a/print/cups-pstoraster/Makefile
+++ b/print/cups-pstoraster/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cups-pstoraster
-PORTVERSION= 8.15
+PORTVERSION= 8.15.3
CATEGORIES= print
MASTER_SITES= \
ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/%SUBDIR%/ \
@@ -14,35 +14,32 @@ MASTER_SITES= \
ftp://ftp3.easysw.com/pub/%SUBDIR%/ \
http://ftp.easysw.com/pub/%SUBDIR%/ \
http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/%SUBDIR%/
-MASTER_SITE_SUBDIR= ghostscript/test
+MASTER_SITE_SUBDIR= ghostscript/${PORTVERSION}
DIST_SUBDIR= ghostscript
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= frank@exit.com
COMMENT= Postscript interpreter for CUPS printing to non-PS printers
-PATCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/${GHOSTSCRIPT_PORT}:patch
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
-ESPGS_VER= ${PORTVERSION}rc3
+ESPGS_VER= ${PORTVERSION}
+GS_VERSION= 8.15
DISTNAME= espgs-${ESPGS_VER}-source
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - espgs-${ESPGS_VER}/pstoraster
-ESPGS_WRKSRC= ${WRKDIR}/espgs-${ESPGS_VER}/pstoraster
-WRKSRC= ${WRKDIRPREFIX}$$(${REALPATH} ${PORTSDIR})/${GHOSTSCRIPT_PORT}/work/ghostscript
-PATCH_WRKSRC= ${ESPGS_WRKSRC}
+WRKSRC= ${WRKDIR}/espgs-${PORTVERSION}
+
+DATADIR= ${TARGETDIR}/share/ghostscript
USE_BZIP2= yes
-USE_GHOSTSCRIPT_RUN= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --without-x --without-ijs --without-gimp-print \
- --with-gs=espgs
+CONFIGURE_ARGS= --without-x --with-gs=espgs
MAKE_ARGS= CFLAGS_STANDARD="${CFLAGS} -DUPD_SIGNAL=0" \
DEVICE_DEVS="\$$(DD)cups.dev \$$(DD)pxlcolor.dev \$$(DD)pxlmono.dev"
-
+PLIST_SUB= GS_VERSION="${GS_VERSION}"
PLIST_FILES= bin/espgs etc/cups/pstoraster.convs \
libexec/cups/filter/pstopxl libexec/cups/filter/pstoraster \
share/cups/model/pxlcolor.ppd share/cups/model/pxlmono.ppd
@@ -51,15 +48,19 @@ PLIST_FILES= bin/espgs etc/cups/pstoraster.convs \
IGNORE= doesn't build with AFPL version of Ghostscript; please use gnu ghostscript instead
.endif
+pre-configure:
+ ${RM} -f ${WRKSRC}/ijs/config.guess ${WRKSRC}/ijs/missing ${WRKSRC}/ijs/config.sub ${WRKSRC}/ijs/install-sh ${WRKSRC}/ijs/ltmain.sh
+ ${RM} -f ${WRKSRC}/trunk/ijs/config.guess ${WRKSRC}/trunk/ijs/missing ${WRKSRC}/trunk/ijs/config.sub ${WRKSRC}/trunk/ijs/install-sh ${WRKSRC}/trunk/ijs/ltmain.sh
+
post-patch:
- ${LN} -sf ${ESPGS_WRKSRC}/gdevcups.c ${WRKSRC}/src
+ ${LN} -sf ${WRKSRC}/pstoraster/gdevcups.c ${WRKSRC}/src
${CAT} ${FILESDIR}/cups.contrib.mak >> ${WRKSRC}/src/contrib.mak
.for file in pstopxl pstoraster
${SED} -e 's:@prefix@:${PREFIX}:g ; \
s:@exec_prefix@:${PREFIX}:g ; \
s:@bindir@:${PREFIX}/bin:g ; \
s:@GS@:espgs:g' \
- ${ESPGS_WRKSRC}/${file}.in > ${ESPGS_WRKSRC}/${file}
+ ${WRKSRC}/pstoraster/${file}.in > ${WRKSRC}/pstoraster/${file}
.endfor
${REINPLACE_CMD} -e 's|^CFLAGS=|CFLAGS=@CPPFLAGS@ |g ; \
s|^LDFLAGS=|LDFLAGS=@LDFLAGS@ |g ; \
@@ -69,14 +70,4 @@ pre-build:
${MKDIR} ${WRKSRC}/bin
${MKDIR} ${WRKSRC}/obj
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/espgs ${PREFIX}/bin
- ${INSTALL_DATA} ${ESPGS_WRKSRC}/pstoraster.convs ${PREFIX}/etc/cups
-.for _file in pstopxl pstoraster
- ${INSTALL_SCRIPT} ${ESPGS_WRKSRC}/${_file} ${PREFIX}/libexec/cups/filter
-.endfor
-.for _file in pxlcolor.ppd pxlmono.ppd
- ${INSTALL_DATA} ${ESPGS_WRKSRC}/${_file} ${PREFIX}/share/cups/model
-.endfor
-
.include <bsd.port.mk>