aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript-gnu-commfont/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'print/ghostscript-gnu-commfont/Makefile.common')
-rw-r--r--print/ghostscript-gnu-commfont/Makefile.common70
1 files changed, 70 insertions, 0 deletions
diff --git a/print/ghostscript-gnu-commfont/Makefile.common b/print/ghostscript-gnu-commfont/Makefile.common
new file mode 100644
index 000000000000..8eef0a8f13e6
--- /dev/null
+++ b/print/ghostscript-gnu-commfont/Makefile.common
@@ -0,0 +1,70 @@
+PORTNAME= ghostscript
+PORTVERSION= 7.05
+CATEGORIES= print
+MASTER_SITES= # nonexistent
+PKGNAMESUFFIX= -gnu
+DISTNAME= # nonexistent
+DISTFILES= # empty
+
+MAINTAINER?= mita@FreeBSD.org
+
+RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu \
+ ${LOCALBASE}/share/ghostscript/Resource/ai0/CMap/Identity-H:${PORTSDIR}/print/adobe-cmaps
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+GSLIB_DIR= ${PREFIX}/share/ghostscript/${PORTVERSION}/lib
+PLIST_SUB= GS_VERSION=${PORTVERSION}
+
+.if defined(COMMFONT)
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-commfont
+PLIST= ${PKGDIR}/pkg-plist.common
+.else
+RUN_DEPENDS+= ${LOCALBASE}/share/ghostscript/${PORTVERSION}/lib/gs_init.ps.pre_sed:${PORTSDIR}/print/ghostscript-gnu-commfont
+PLIST_SUB+= CIDFNMAP="${CIDFNMAP}"
+.if defined(JPNFONT)
+CATEGORIES+= japanese
+PKGNAMEPREFIX= ja-
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-jpnfont
+RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/TrueType/kochi-mincho.ttf:${PORTSDIR}/japanese/kochi-ttfonts
+CIDFNMAP= CIDFnmap.jp
+.elif defined(KORFONT)
+CATEGORIES+= korean
+PKGNAMEPREFIX= ko-
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-korfont
+RUN_DEPENDS+= ${LOCALBASE}/share/ghostscript/fonts/Munhwa-Bold:${PORTSDIR}/korean/munhwafonts-cid
+CIDFNMAP= CIDFnmap.ko
+.endif
+.endif
+
+do-configure:
+.if !defined(COMMFONT)
+ ${SED} -e 's:%%LOCALBASE%%:${LOCALBASE}:g' \
+ -e 's:%%X11BASE%%:${X11BASE}:g' \
+ ${FILESDIR}/${CIDFNMAP} > ${WRKSRC}/${CIDFNMAP}
+.endif
+
+do-install:
+.if defined(COMMFONT)
+ ${MV} ${GSLIB_DIR}/gs_init.ps ${GSLIB_DIR}/gs_init.ps.pre_sed
+ ${SED} -e "s:^%.*(a4):(a4):" ${GSLIB_DIR}/gs_init.ps.pre_sed > \
+ ${GSLIB_DIR}/gs_init.ps
+.else
+ ${INSTALL_DATA} ${WRKSRC}/${CIDFNMAP} ${GSLIB_DIR}
+ ${MV} ${GSLIB_DIR}/CIDFnmap ${GSLIB_DIR}/CIDFnmap.orig
+ ${GREP} -v -e "${CIDFNMAP}" ${GSLIB_DIR}/CIDFnmap.orig > \
+ ${GSLIB_DIR}/CIDFnmap
+ ${ECHO_CMD} '(${CIDFNMAP}) .runlibfile' >> ${GSLIB_DIR}/CIDFnmap
+.endif
+
+post-install:
+.if defined(KORFONT)
+.for i in Munhwa-Bold Munhwa-Regular MunhwaGothic-Bold MunhwaGothic-Regular
+ ${LN} -sf ${PREFIX}/share/ghostscript/fonts/${i} \
+ ${PREFIX}/share/ghostscript/Resource/CIDFont/${i}
+ ${ECHO_CMD} "share/ghostscript/Resource/CIDFont/${i}" >> ${TMPPLIST}
+.endfor
+.endif
+
+.include <bsd.port.mk>