aboutsummaryrefslogtreecommitdiff
path: root/print/latex-booktabs
diff options
context:
space:
mode:
Diffstat (limited to 'print/latex-booktabs')
-rw-r--r--print/latex-booktabs/Makefile48
-rw-r--r--print/latex-booktabs/distinfo4
-rw-r--r--print/latex-booktabs/pkg-descr6
-rw-r--r--print/latex-booktabs/pkg-plist9
4 files changed, 67 insertions, 0 deletions
diff --git a/print/latex-booktabs/Makefile b/print/latex-booktabs/Makefile
new file mode 100644
index 000000000000..442c92a5a68e
--- /dev/null
+++ b/print/latex-booktabs/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: latex-booktabs
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-booktabs
+PORTVERSION= 1.618.20030328
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/booktabs
+DISTFILES= ${DOC_FILES} ${CLASS_FILES}
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= #empty
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package for publication quality tables
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS+= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+NO_BUILD= YES
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/latex
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+
+DOC_FILES= booktabs.pdf
+
+CLASS_FILES= booktabs.dtx booktabs.ins booktabs.sty
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-booktabs/distinfo b/print/latex-booktabs/distinfo
new file mode 100644
index 000000000000..91104d2f28b1
--- /dev/null
+++ b/print/latex-booktabs/distinfo
@@ -0,0 +1,4 @@
+MD5 (latex-booktabs/booktabs.pdf) = 755d190f924af9d3b898c15a67b65a42
+MD5 (latex-booktabs/booktabs.dtx) = 1b48e8b965d9ac76e2899aaec5ae7591
+MD5 (latex-booktabs/booktabs.ins) = 684a0340272e5a0b68c5c8eda9b78b1f
+MD5 (latex-booktabs/booktabs.sty) = fde7b309aac8a7d5a7aff663e89e829c
diff --git a/print/latex-booktabs/pkg-descr b/print/latex-booktabs/pkg-descr
new file mode 100644
index 000000000000..0c8611c29819
--- /dev/null
+++ b/print/latex-booktabs/pkg-descr
@@ -0,0 +1,6 @@
+booktabs is to enable the easy production of tables such as should
+appear in published scientific books and journals. What distinguishes
+these from plain LaTeX tables is the default use of additional space
+above and below rules, and rules of varying `thickness'. What further
+distinguishes them from the tables many people do produce using LaTeX
+is the absence of vertical rules and double rules.
diff --git a/print/latex-booktabs/pkg-plist b/print/latex-booktabs/pkg-plist
new file mode 100644
index 000000000000..4e1986cf2ca1
--- /dev/null
+++ b/print/latex-booktabs/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/booktabs.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/booktabs.dtx
+%%CLASSDIR%%/booktabs.ins
+%%CLASSDIR%%/booktabs.sty
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%