aboutsummaryrefslogtreecommitdiff
path: root/print/libgnomeprint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/libgnomeprint/Makefile')
-rw-r--r--print/libgnomeprint/Makefile24
1 files changed, 14 insertions, 10 deletions
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index 2cc5717e6710..a7f58f3a5c9b 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -3,14 +3,14 @@
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/print/libgnomeprint/Makefile,v 1.54 2005/09/26 21:07:03 marcus Exp $
#
PORTNAME= libgnomeprint
-PORTVERSION= 2.10.3
-PORTREVISION= 1
+PORTVERSION= 2.12.1
CATEGORIES= print gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -19,14 +19,15 @@ COMMENT= Gnome print support library
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
popt.0:${PORTSDIR}/devel/popt
+USE_BISON= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomehier glib20 pango libxml2 \
- libartlgpl2
+ libartlgpl2 ltverhack
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -35,11 +36,7 @@ PLIST_SUB= VERSION=${PORTVERSION} \
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libcups.so)
-WITH_CUPS= yes
-.endif
-
-.if defined(WITH_CUPS) && !defined(WITHOUT_CUPS)
+.if defined(WITH_CUPS) || exists(${LOCALBASE}/lib/libcups.so)
CONFIGURE_ARGS+= --with-cups
LIB_DEPENDS+= gnomecups-1.0:${PORTSDIR}/print/libgnomecups
PLIST_SUB+= CUPS:=""
@@ -48,6 +45,13 @@ CONFIGURE_ARGS+= --without-cups
PLIST_SUB+= CUPS:="@comment "
.endif
+pre-everything::
+.if !defined(WITH_CUPS)
+ @${ECHO_MSG} " Enable cups support by defining"
+ @${ECHO_MSG} " WITH_CUPS"
+ @${ECHO_MSG} ""
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
's|<malloc[.]h>|<stdlib.h>|'