aboutsummaryrefslogtreecommitdiff
path: root/print/py-reportlab
diff options
context:
space:
mode:
Diffstat (limited to 'print/py-reportlab')
-rw-r--r--print/py-reportlab/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/print/py-reportlab/Makefile b/print/py-reportlab/Makefile
index a093274f3e23..1a58357fd797 100644
--- a/print/py-reportlab/Makefile
+++ b/print/py-reportlab/Makefile
@@ -31,6 +31,14 @@ EXAMPLEDIR= ${PREFIX}/share/examples/reportlab
post-patch:
${MV} ${WRKSRC}/lib/setup.py ${WRKDIR}
+do-build:
+ @(cd ${WRKDIR}; \
+ ${PYTHON_CMD} setup.py build)
+
+do-install:
+ @(cd ${WRKDIR}; \
+ ${PYTHON_CMD} setup.py install -c -O1 --prefix="${PREFIX}")
+
post-install:
${MKDIR} ${REPORTLABDIR}/fonts
.for fontfile in LeERC___.AFM LeERC___.PFB