aboutsummaryrefslogtreecommitdiff
path: root/print/py-vharfbuzz/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/py-vharfbuzz/Makefile')
-rw-r--r--print/py-vharfbuzz/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/print/py-vharfbuzz/Makefile b/print/py-vharfbuzz/Makefile
new file mode 100644
index 000000000000..a9a45dab9f7a
--- /dev/null
+++ b/print/py-vharfbuzz/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= vharfbuzz
+PORTVERSION= 0.1.1
+CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= User-friendlier way to use Harfbuzz in Python
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fonttools>=0:print/py-fonttools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}uharfbuzz>=0:print/py-uharfbuzz@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>