aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/py-rtf/Makefile28
-rw-r--r--print/py-rtf/distinfo2
-rw-r--r--print/py-rtf/pkg-descr5
-rw-r--r--print/py-rtf/pkg-plist28
5 files changed, 64 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index a71a225e2282..7af67c356ab3 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -239,6 +239,7 @@
SUBDIR += py-fonttools
SUBDIR += py-freetype
SUBDIR += py-reportlab
+ SUBDIR += py-rtf
SUBDIR += rlpr
SUBDIR += rprint
SUBDIR += rtf2latex
diff --git a/print/py-rtf/Makefile b/print/py-rtf/Makefile
new file mode 100644
index 000000000000..21eb3ad3ec00
--- /dev/null
+++ b/print/py-rtf/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: PyRTF
+# Date created: 09 May 2005
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtf
+PORTVERSION= 0.45
+CATEGORIES= print python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pyrtf
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyRTF-${PORTVERSION}
+
+MAINTAINER= tg@FreeBSD.org
+COMMENT= Library to create RTF documents using the Python language
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+EXAMPLESDIR= ${PREFIX}/share/examples/py-rtf
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/print/py-rtf/distinfo b/print/py-rtf/distinfo
new file mode 100644
index 000000000000..fb3a9d630cf3
--- /dev/null
+++ b/print/py-rtf/distinfo
@@ -0,0 +1,2 @@
+MD5 (PyRTF-0.45.tar.gz) = 6da40728b27c6a0150291f19c3f2ceb9
+SIZE (PyRTF-0.45.tar.gz) = 32837
diff --git a/print/py-rtf/pkg-descr b/print/py-rtf/pkg-descr
new file mode 100644
index 000000000000..012cfd141102
--- /dev/null
+++ b/print/py-rtf/pkg-descr
@@ -0,0 +1,5 @@
+PyRTF is a pure python module for the efficient generation of
+rich text format documents. It has good support for tables and
+tries to maintain compatibility with as many RTF readers as possible.
+
+WWW: http://pyrtf.sourceforge.net/
diff --git a/print/py-rtf/pkg-plist b/print/py-rtf/pkg-plist
new file mode 100644
index 000000000000..04e4544a5811
--- /dev/null
+++ b/print/py-rtf/pkg-plist
@@ -0,0 +1,28 @@
+%%PYTHON_SITELIBDIR%%/PyRTF/Constants.py
+%%PYTHON_SITELIBDIR%%/PyRTF/Constants.pyc
+%%PYTHON_SITELIBDIR%%/PyRTF/Constants.pyo
+%%PYTHON_SITELIBDIR%%/PyRTF/Elements.py
+%%PYTHON_SITELIBDIR%%/PyRTF/Elements.pyc
+%%PYTHON_SITELIBDIR%%/PyRTF/Elements.pyo
+%%PYTHON_SITELIBDIR%%/PyRTF/PropertySets.py
+%%PYTHON_SITELIBDIR%%/PyRTF/PropertySets.pyc
+%%PYTHON_SITELIBDIR%%/PyRTF/PropertySets.pyo
+%%PYTHON_SITELIBDIR%%/PyRTF/Renderer.py
+%%PYTHON_SITELIBDIR%%/PyRTF/Renderer.pyc
+%%PYTHON_SITELIBDIR%%/PyRTF/Renderer.pyo
+%%PYTHON_SITELIBDIR%%/PyRTF/Styles.py
+%%PYTHON_SITELIBDIR%%/PyRTF/Styles.pyc
+%%PYTHON_SITELIBDIR%%/PyRTF/Styles.pyo
+%%PYTHON_SITELIBDIR%%/PyRTF/__init__.py
+%%PYTHON_SITELIBDIR%%/PyRTF/__init__.pyc
+%%PYTHON_SITELIBDIR%%/PyRTF/__init__.pyo
+share/examples/py-rtf/examples.py
+share/examples/py-rtf/examples2.py
+share/examples/py-rtf/image.jpg
+share/examples/py-rtf/img1.png
+share/examples/py-rtf/img2.png
+share/examples/py-rtf/img3.png
+share/examples/py-rtf/img4.png
+share/examples/py-rtf/merged_cells.py
+@dirrm share/examples/py-rtf
+@dirrm %%PYTHON_SITELIBDIR%%/PyRTF