aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/pslib/Makefile4
-rw-r--r--print/pslib/files/patch-src__bmp.c8
2 files changed, 4 insertions, 8 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 2dcc5bc9999d..c49c38e18ad7 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -30,10 +30,6 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-.if ${ARCH}==sparc64
-BROKEN= does not compile on ${ARCH}
-.endif
-
.if defined(WITHOUT_NLS)
CONFIGURE_ENV+= ac_cv_header_libintl_h=no
PLIST_SUB+= NLS="@comment "
diff --git a/print/pslib/files/patch-src__bmp.c b/print/pslib/files/patch-src__bmp.c
index 981e8d46e949..6eca084b0acd 100644
--- a/print/pslib/files/patch-src__bmp.c
+++ b/print/pslib/files/patch-src__bmp.c
@@ -1,5 +1,5 @@
---- src/bmp.c.orig Mon Apr 24 23:25:31 2006
-+++ src/bmp.c Thu Jun 8 18:59:00 2006
+--- src/bmp.c.orig Mon Apr 24 10:25:31 2006
++++ src/bmp.c Sat Jul 8 13:02:51 2006
@@ -41,10 +41,28 @@
#include <fcntl.h>
#include <unistd.h>
@@ -12,8 +12,8 @@
+#include <sys/endian.h>
+
+#if __FreeBSD_version >= 500000
-+#define BMPSwabShort(x) bswap16(x)
-+#define BMPSwabLong(x) bswap32(x)
++#define BMPSwabShort(x) *x = bswap16(*x)
++#define BMPSwabLong(x) *x = bswap32(*x)
+#else
+#define BMPSwabShort(x) (be16toh(x))
+#define BMPSwabLong(x) (be32toh(x))