aboutsummaryrefslogtreecommitdiff
path: root/science/libkml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/libkml/Makefile')
-rw-r--r--science/libkml/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/science/libkml/Makefile b/science/libkml/Makefile
new file mode 100644
index 000000000000..53ff694f0192
--- /dev/null
+++ b/science/libkml/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libkml
+# Date created: 3rd Oct, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libkml
+PORTVERSION= 1.0.1
+CATEGORIES= science
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Library for parse, generate and operate on KML
+
+BUILD_DEPENDS= ${LOCALBASE}/include/expat.h:${PORTSDIR}/textproc/expat2 \
+ ${LOCALBASE}/bin/curl-config:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.mk>