aboutsummaryrefslogtreecommitdiff
path: root/science/qcl
diff options
context:
space:
mode:
Diffstat (limited to 'science/qcl')
-rw-r--r--science/qcl/Makefile29
-rw-r--r--science/qcl/distinfo2
-rw-r--r--science/qcl/files/patch-aa124
-rw-r--r--science/qcl/pkg-descr5
-rw-r--r--science/qcl/pkg-plist13
-rw-r--r--science/qcl/scripts/configure5
6 files changed, 0 insertions, 178 deletions
diff --git a/science/qcl/Makefile b/science/qcl/Makefile
deleted file mode 100644
index ed7ece66ec39..000000000000
--- a/science/qcl/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-# ports collection makefile for: qcl
-# Date created: 23 May 2001
-# Whom: Brad Huntting <huntting@glarp.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= qcl
-PORTVERSION= 0.4.1
-PORTREVISION= 1
-CATEGORIES= emulators math
-MASTER_SITES= http://tph.tuwien.ac.at/~oemer/tgz/
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= huntting@glarp.com
-COMMENT= A quantum computer simulator
-
-USE_GETOPT_LONG=yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
-post-install:
- ${STRIP_CMD} ${PREFIX}/bin/qcl
-
-.include <bsd.port.post.mk>
diff --git a/science/qcl/distinfo b/science/qcl/distinfo
deleted file mode 100644
index 056d3205e1ea..000000000000
--- a/science/qcl/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (qcl-0.4.1.tgz) = 0ff6cdb3c29cc3c533f3b27018662a57
-SIZE (qcl-0.4.1.tgz) = 97862
diff --git a/science/qcl/files/patch-aa b/science/qcl/files/patch-aa
deleted file mode 100644
index 9b3bc17cd883..000000000000
--- a/science/qcl/files/patch-aa
+++ /dev/null
@@ -1,124 +0,0 @@
---- Makefile.orig Wed Jan 17 13:17:06 2001
-+++ Makefile Thu May 24 15:51:01 2001
-@@ -14,29 +14,25 @@
-
- # Directory for Standard .qcl files
-
--QCLDIR = /usr/local/lib/qcl
-+QCLDIR = ${PREFIX}/share/qcl
-
- # Path for qcl binaries
-
--QCLBIN = /usr/local/bin
-+QCLBIN = ${PREFIX}/bin
-
- # Debugging options
-
--DEBUG = -g -DQCL_DEBUG -DQC_DEBUG
--#DEBUG = -O2
-+DEBUG =
-
- # Comment out if you don't have GNU readline on your system
- # explicit linking against libtermcap or libncurses may be required
-
- RLOPT = -DQCL_USE_READLINE
--#RLLIB = -lreadline
--RLLIB = -lreadline -lncurses
-+RLLIB = -lreadline
-
- # Replace with lex and yacc on non-GNU systems (untested)
-
--LEX = flex
--YACC = bison
--INSTALL = install
-+INSTALL = install -c
-
- ##### You shouldn't have to edit the stuff below #####
-
-@@ -44,13 +40,15 @@
- QCLIB = $(QCDIR)/libqc.a
- QCLINC = lib
-
--CC = g++
--CPP = $(CC) -E
--CFLAGS = -c -Wall $(DEBUG) $(RLOPT) -I$(QCDIR) -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
--LFLAGS = -L$(QCDIR) $(DEBUG) -lm -lfl -lqc $(RLLIB)
-+CXXFLAGS += -Wall $(DEBUG) $(RLOPT) -I$(QCDIR) -I${PREFIX}/include -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
-+LDFLAGS += -L$(QCDIR) $(DEBUG) -L${PREFIX}/lib -lgnugetopt -lm -lfl -lqc $(RLLIB)
-+
-+FILESCC = debug.cc error.cc eval.cc exec.cc extern.cc lex.cc \
-+ options.cc parse.cc print.cc qcl.cc quheap.cc symbols.cc \
-+ syntax.cc typcheck.cc types.cc yacc.cc
-+FILESH = debug.h error.h extern.h options.h parse.h quheap.h \
-+ symbols.h syntax.h types.h yacc.h
-
--FILESCC = $(wildcard *.cc)
--FILESH = $(wildcard *.h)
-
- SOURCE = $(FILESCC) $(FILESH) qcl.lex qcl.y Makefile
-
-@@ -58,23 +56,11 @@
- lex.o yacc.o print.o quheap.o extern.o eval.o exec.o \
- parse.o options.o debug.o
-
--all: do-it-all
-+all: build
-+
-
--ifeq (.depend,$(wildcard .depend))
--include .depend
--do-it-all: build
--else
--do-it-all: dep
-- make
--endif
--
--#### Rules for depend
--
--dep: lex.cc yacc.cc yacc.h $(QCLIB)
-- for i in *.cc; do \
-- $(CPP) -I$(QCDIR) -MM $$i; \
-- echo -e '\t$(CC) $(CFLAGS)' $$i '\n'; \
-- done > .depend
-+dep: $(FILESCC) $(FILESH)
-+ $(CXX) -M $(CXXFLAGS) $(FILESCC) >.depend
-
- lex.cc: qcl.lex
- $(LEX) -olex.cc qcl.lex
-@@ -86,24 +72,24 @@
- mv yacc.cc.h yacc.h
-
- $(QCLIB):
-- cd $(QCDIR) && make libqc.a
-+ cd $(QCDIR) && $(MAKE) $(MAKEFLAGS) libqc.a
-
- #### Rules for build
-
- build: qcl $(QCLINC)/default.qcl
-
- qcl: $(OBJECTS) qcl.o $(QCLIB)
-- $(CC) $(OBJECTS) qcl.o $(LFLAGS) -o qcl
-+ $(CXX) $(OBJECTS) qcl.o $(LDFLAGS) -o qcl
-
- qcl-static: $(OBJECTS) qcl.o $(QCLIB)
-- $(CC) -static $(OBJECTS) qcl.o $(LFLAGS) -o qcl-static
-+ $(CXX) -static $(OBJECTS) qcl.o $(LDFLAGS) -o qcl-static
- strip qcl-static
-
- $(QCLINC)/default.qcl: extern.cc
- grep "^//!" extern.cc | cut -c5- > $(QCLINC)/default.qcl
-
- install: build
-- $(INSTALL) -m 0755 -d $(QCLBIN) $(QCLDIR)
-+ umask 022; mkdir -p $(QCLDIR); chmod 0755 $(QCLDIR)
- $(INSTALL) -m 0755 ./qcl $(QCLBIN)
- $(INSTALL) -m 0644 ./lib/default.qcl $(QCLDIR)
- $(INSTALL) -m 0644 ./lib/dft.qcl $(QCLDIR)
-@@ -115,6 +101,7 @@
- $(INSTALL) -m 0644 ./lib/roulette.qcl $(QCLDIR)
- $(INSTALL) -m 0644 ./lib/shor.qcl $(QCLDIR)
- $(INSTALL) -m 0644 ./lib/swap.qcl $(QCLDIR)
-+ $(INSTALL) -m 0644 ./lib/grover.qcl $(QCLDIR)
-
- #### Other Functions
-
diff --git a/science/qcl/pkg-descr b/science/qcl/pkg-descr
deleted file mode 100644
index 272a6df15c1b..000000000000
--- a/science/qcl/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This is a port of qcl, a quantum computer simulator.
-
-WWW: http://tph.tuwien.ac.at/~oemer/qcl.html
-
-- brad.huntting@glarp.com
diff --git a/science/qcl/pkg-plist b/science/qcl/pkg-plist
deleted file mode 100644
index 3df3c22741f3..000000000000
--- a/science/qcl/pkg-plist
+++ /dev/null
@@ -1,13 +0,0 @@
-bin/qcl
-share/qcl/default.qcl
-share/qcl/dft.qcl
-share/qcl/expmod.qcl
-share/qcl/fanout.qcl
-share/qcl/functions.qcl
-share/qcl/modarith.qcl
-share/qcl/qufunct.qcl
-share/qcl/roulette.qcl
-share/qcl/shor.qcl
-share/qcl/swap.qcl
-share/qcl/grover.qcl
-@dirrm share/qcl
diff --git a/science/qcl/scripts/configure b/science/qcl/scripts/configure
deleted file mode 100644
index 24c2ff96fdd1..000000000000
--- a/science/qcl/scripts/configure
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-cd $WRKSRC
-rm -f .depend
-make dep