aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/afni/Makefile8
-rw-r--r--science/felt/Makefile2
-rw-r--r--science/xmakemol/Makefile8
3 files changed, 6 insertions, 12 deletions
diff --git a/science/afni/Makefile b/science/afni/Makefile
index e490f4aee4ee..dc4605b41efe 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -23,8 +23,7 @@ EXTRACT_ONLY= afni_src.tgz CA_EZ_v1.5-July3107.tgz
MAINTAINER= jwbacon@tds.net
COMMENT= Advanced Functional Neuro Imaging
-LIB_DEPENDS= Xm:${PORTSDIR}/x11-toolkits/open-motif \
- R:${PORTSDIR}/math/R \
+LIB_DEPENDS= R:${PORTSDIR}/math/R \
gsl:${PORTSDIR}/math/gsl
RUN_DEPENDS= cjpeg:${PORTSDIR}/graphics/jpeg \
mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
@@ -32,6 +31,8 @@ RUN_DEPENDS= cjpeg:${PORTSDIR}/graphics/jpeg \
ppmtogif:${PORTSDIR}/graphics/netpbm \
endian:${PORTSDIR}/sysutils/endian
+USES= gettext iconv gmake motif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
@@ -40,9 +41,6 @@ BROKEN= Does not compile on sparc64: "undefined reference to '_mcount'"
USE_GL= glw glu
USE_XORG= xi
-USE_GMAKE= yes
-USES= gettext iconv
-USE_MOTIF= yes
MAKE_ENV= CC="${CC}"
MAKE_JOBS_UNSAFE=yes
diff --git a/science/felt/Makefile b/science/felt/Makefile
index 469fbcf6b48e..ef0562f7ae3c 100644
--- a/science/felt/Makefile
+++ b/science/felt/Makefile
@@ -16,8 +16,8 @@ OPTIONS_DEFINE= DOCS EXAMPLES
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USES= motif
USE_BZIP2= yes
-USE_MOTIF= yes
USE_GL= glu glw
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" \
diff --git a/science/xmakemol/Makefile b/science/xmakemol/Makefile
index 32dda8928c72..f937d825376e 100644
--- a/science/xmakemol/Makefile
+++ b/science/xmakemol/Makefile
@@ -1,8 +1,5 @@
-# New ports collection makefile for: xmakemol
-# Date created: 8 June, 2001
-# Whom: Chi
+# Created by: Chi
# $FreeBSD$
-#
PORTNAME= xmakemol
PORTVERSION= 5.16
@@ -13,10 +10,9 @@ MASTER_SITES= SAVANNAH
MAINTAINER= ports@FreeBSD.org
COMMENT= Molecule Viewer Program Based on Motif Widget
+USES= gmake motif
USE_XORG= xpm
USE_GL= glut glw
-USE_MOTIF= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= xmakemol.1