aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/hs-bio/Makefile4
-rw-r--r--science/hs-bio/files/patch-Bio_Alignment_Bowtie.hs7
-rw-r--r--science/hs-bio/files/patch-examples__RSelectPE.hs8
3 files changed, 9 insertions, 10 deletions
diff --git a/science/hs-bio/Makefile b/science/hs-bio/Makefile
index 9910dc693d39..d978ddb89198 100644
--- a/science/hs-bio/Makefile
+++ b/science/hs-bio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bio
PORTVERSION= 0.5.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= Bioinformatics library
LICENSE= LGPL21
-USE_CABAL= mtl parallel parsec QuickCheck>=2 random tagsoup>=0.8
+USE_CABAL= mtl old-time parallel parsec QuickCheck>=2 random tagsoup>=0.8
EXECUTABLE= fastout flowclip flx frecover frename orf rselect-pe
diff --git a/science/hs-bio/files/patch-Bio_Alignment_Bowtie.hs b/science/hs-bio/files/patch-Bio_Alignment_Bowtie.hs
new file mode 100644
index 000000000000..f7ba1305fb88
--- /dev/null
+++ b/science/hs-bio/files/patch-Bio_Alignment_Bowtie.hs
@@ -0,0 +1,7 @@
+--- Bio/Alignment/Bowtie.hs.orig 2013-07-20 07:25:31 UTC
++++ Bio/Alignment/Bowtie.hs
+@@ -1,3 +1,4 @@
++{-# LANGUAGE FlexibleContexts #-}
+ {-| This module provides a data type to represent an alignment
+ produced by the Bowtie short-read alignment tool (see
+ <http://bowtie-bio.sourceforge.net/index.shtml>).
diff --git a/science/hs-bio/files/patch-examples__RSelectPE.hs b/science/hs-bio/files/patch-examples__RSelectPE.hs
deleted file mode 100644
index 6ca244b9f7c4..000000000000
--- a/science/hs-bio/files/patch-examples__RSelectPE.hs
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./examples/RSelectPE.hs.orig 2011-12-15 12:56:28.000000000 +0100
-+++ ./examples/RSelectPE.hs 2011-12-17 11:46:58.000000000 +0100
-@@ -1,5 +1,3 @@
--{- | Randomly select paired end (illumina) reads -}
--
- import System.Environment (getArgs)
- import Data.List (isSuffixOf)
- import System.Random