aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/ergo/Makefile2
-rw-r--r--science/ghmm/Makefile2
-rw-r--r--science/silo/Makefile2
3 files changed, 6 insertions, 0 deletions
diff --git a/science/ergo/Makefile b/science/ergo/Makefile
index d4ed53f3e719..b787a939e117 100644
--- a/science/ergo/Makefile
+++ b/science/ergo/Makefile
@@ -19,6 +19,8 @@ SHEBANG_FILES= test/check_eigenvectors.sh test/compare_homo_lumo.sh
GNU_CONFIGURE= yes
+CONFLICTS_INSTALL= ergo-irc-server # bin/ergo
+
TEST_TARGET= check
OPTIONS_DEFINE_amd64= SSE
diff --git a/science/ghmm/Makefile b/science/ghmm/Makefile
index 6f9a02e433c4..bf051a511dd0 100644
--- a/science/ghmm/Makefile
+++ b/science/ghmm/Makefile
@@ -20,4 +20,6 @@ CONFIGURE_ARGS+= --without-python
USE_LDCONFIG= yes
+CONFLICTS_INSTALL= graphviz # bin/cluster
+
.include <bsd.port.mk>
diff --git a/science/silo/Makefile b/science/silo/Makefile
index 2e988ae288eb..d9a025fcf2c1 100644
--- a/science/silo/Makefile
+++ b/science/silo/Makefile
@@ -20,6 +20,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --disable-static
INSTALL_TARGET= install-strip
+CONFLICTS_INSTALL= deforaos-browser # bin/browser
+
OPTIONS_DEFINE= FORTRAN HDF5 PYTHON
OPTIONS_DEFAULT= HDF5
OPTIONS_SUB= yes