aboutsummaryrefslogtreecommitdiff
path: root/security/botan2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/botan2/Makefile')
-rw-r--r--security/botan2/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index 1023ab61a643..97161ad4557b 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -1,5 +1,5 @@
PORTNAME= botan
-DISTVERSION= 2.17.3
+DISTVERSION= 2.18.0
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/releases/
PKGNAMESUFFIX= 2
@@ -34,18 +34,20 @@ LDFLAGS+= -pthread
DOCSDIR= ${LOCALBASE}/share/doc/${PORTNAME}-${PORTVERSION}
-_SOABIVER= 17
+_SOABIVER= 18
_SHLIBVER= ${DISTVERSION:S/./ /g:[2]}
_SHLIBVERPATCH= ${DISTVERSION:S/./ /g:[3]}
-PLIST_SUB= SOABIVER=${_SOABIVER} SHLIBVER=${_SHLIBVER} SHLIBVERPATCH=${_SHLIBVERPATCH}
+PLIST_SUB= SHLIBVER=${_SHLIBVER} \
+ SHLIBVERPATCH=${_SHLIBVERPATCH} \
+ SOABIVER=${_SOABIVER}
PORTDOCS= *
OPTIONS_DEFINE= DOCS PYTHON SQLITE3 SSL
OPTIONS_DEFAULT= SSL
OPTIONS_SUB= yes
-PYTHON_USES= python
-PYTHON_USES_OFF= python:build
+PYTHON_USES= python:3.6+
+PYTHON_USES_OFF= python:3.6+,build
PYTHON_CONFIGURE_ON= --with-python-versions=${PYTHON_VER}
PYTHON_CONFIGURE_OFF= --no-install-python-module