aboutsummaryrefslogtreecommitdiff
path: root/security/cfs
diff options
context:
space:
mode:
Diffstat (limited to 'security/cfs')
-rw-r--r--security/cfs/Makefile6
-rw-r--r--security/cfs/files/patch-ac20
2 files changed, 4 insertions, 22 deletions
diff --git a/security/cfs/Makefile b/security/cfs/Makefile
index be02129b97dc..261478ad8183 100644
--- a/security/cfs/Makefile
+++ b/security/cfs/Makefile
@@ -7,21 +7,17 @@
PORTNAME= cfs
PORTVERSION= 1.4.1
-PORTREVESION= 2
+PORTREVESION= 1
CATEGORIES= security
MASTER_SITES= http://www.crypto.com/software/
MAINTAINER= green@FreeBSD.org
COMMENT= A cryptographic file system implemented as a user-space NFS server
-USE_REINPLACE= yes
ALL_TARGET= cfs
MAN1= cattach.1 cdetach.1 cmkdir.1 cpasswd.1 cfssh.1
MAN8= ccat.8 cfsd.8 cname.8
-post-patch:
- ${REINPLACE_CMD} 's/^\.TH SSH/.TH CFSSH/' ${WRKSRC}/cfssh.1
-
do-install:
@cd ${WRKSRC}; \
${INSTALL_PROGRAM} ccat cfsd cname ${PREFIX}/sbin; \
diff --git a/security/cfs/files/patch-ac b/security/cfs/files/patch-ac
index bd3f9d95a2fa..bf63c532aede 100644
--- a/security/cfs/files/patch-ac
+++ b/security/cfs/files/patch-ac
@@ -1,22 +1,8 @@
---- cfssh.orig Wed Dec 3 16:21:40 1997
-+++ cfssh Tue Apr 20 19:45:17 2004
-@@ -1,15 +1,16 @@
+--- cfssh.orig Mon May 22 20:56:00 2000
++++ cfssh Mon May 22 20:56:11 2000
+@@ -1,4 +1,4 @@
-#!/bin/ksh
+#!/bin/sh
if [ -z "$1" ]; then
echo Usage: cfssh directory
- exit
- fi
- export PS1="crypto:`basename $1`$ "
--D=.$RANDOM.$RANDOM
-+set -- $1 `dd if=/dev/urandom bs=8 count=1 2>/dev/null | od -D`
-+D=.$3.$4
- cattach $1 $D || exit 1
- echo "Directory is /crypt/$D"
- cd /crypt/$D
--D=" "
-+D=" "
- CWD=`/bin/pwd`
- D=`basename $CWD`
- PWD=$CWD