aboutsummaryrefslogtreecommitdiff
path: root/security/clamassassin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/clamassassin/Makefile')
-rw-r--r--security/clamassassin/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/security/clamassassin/Makefile b/security/clamassassin/Makefile
index c29123a6f15b..1fdf3fe0c4ed 100644
--- a/security/clamassassin/Makefile
+++ b/security/clamassassin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: clamassassin
-# Date created: 16 October 2004
-# Whom: Matt <matt@xtaz.net>
-#
+# Created by: Matt <matt@xtaz.net>
# $FreeBSD$
-#
PORTNAME= clamassassin
PORTVERSION= 1.2.4
@@ -22,17 +18,19 @@ PLIST_FILES= bin/clamassassin
GNU_CONFIGURE= yes
-OPTIONS= CLAMDSCAN "Scanning using clamd" on \
- SUBREWRITE "Mail subject rewriting" off
+OPTIONS_DEFINE= CLAMDSCAN SUBREWRITE
+OPTIONS_DEFAULT= CLAMDSCAN
+CLAMDSCAN_DESC= Scanning using clamd
+SUBREWRITE_DESC= Mail subject rewriting
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined (WITHOUT_CLAMDSCAN)
+.if ${PORT_OPTIONS:MCLAMDSCAN}
CONFIGURE_ARGS+= --enable-clamdscan
.endif
-.if defined (WITH_SUBREWRITE)
+.if ${PORT_OPTIONS:MSUBREWRITE}
CONFIGURE_ARGS+= --enable-subject-rewrite
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>