aboutsummaryrefslogtreecommitdiff
path: root/security/crowdsec-firewall-bouncer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/crowdsec-firewall-bouncer/Makefile')
-rw-r--r--security/crowdsec-firewall-bouncer/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/security/crowdsec-firewall-bouncer/Makefile b/security/crowdsec-firewall-bouncer/Makefile
new file mode 100644
index 000000000000..cc954af98728
--- /dev/null
+++ b/security/crowdsec-firewall-bouncer/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= crowdsec-firewall-bouncer
+PORTVERSION= 0.0.12
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+
+MAINTAINER= sbz@FreeBSD.org
+COMMENT= Crowdsec bouncer written in golang for firewalls
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= crowdsec>0:security/crowdsec
+
+USES= go:modules
+
+USE_RC_SUBR= crowdsec_firewall
+
+GO_MODULE= github.com/crowdsecurity/cs-firewall-bouncer
+
+GO_BUILDFLAGS= -ldflags "-s -w \
+ -X github.com/crowdsecurity/cs-firewall-bouncer/pkg/version.Version=v${PORTVERSION} \
+ -X github.com/crowdsecurity/cs-firewall-bouncer/pkg/version.Tag=freebsd"
+
+SUB_FILES= pkg-message
+
+post-patch:
+ ${REINPLACE_CMD} 's,$${BACKEND},pf,g' \
+ ${WRKSRC}/config/cs-firewall-bouncer.yaml
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+
+ ${INSTALL_DATA} ${WRKSRC}/config/cs-firewall-bouncer.yaml \
+ ${STAGEDIR}${ETCDIR}/cs-firewall-bouncer.yaml.sample
+
+ ${INSTALL_PROGRAM} ${WRKDIR}/bin/crowdsec-firewall-bouncer \
+ ${STAGEDIR}${PREFIX}/bin/cs-firewall-bouncer
+
+.include <bsd.port.mk>