aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl/scripts/configure.sasl
diff options
context:
space:
mode:
Diffstat (limited to 'security/cyrus-sasl/scripts/configure.sasl')
-rw-r--r--security/cyrus-sasl/scripts/configure.sasl59
1 files changed, 59 insertions, 0 deletions
diff --git a/security/cyrus-sasl/scripts/configure.sasl b/security/cyrus-sasl/scripts/configure.sasl
new file mode 100644
index 000000000000..75c4258fa056
--- /dev/null
+++ b/security/cyrus-sasl/scripts/configure.sasl
@@ -0,0 +1,59 @@
+#!/bin/sh
+# $FreeBSD$
+
+if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
+ exit
+fi
+
+if [ "${BATCH}" ]; then
+ exit
+else
+ /usr/bin/dialog --title "Additional pwcheck methods" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+MySQL "MySQL password Authentication" OFF \
+OpenLDAP "OpenLDAP password Authentication" OFF \
+2> /tmp/checklist.tmp.$$
+
+ retval=$?
+
+ if [ -s /tmp/checklist.tmp.$$ ]; then
+ set `cat /tmp/checklist.tmp.$$`
+ fi
+ rm -f /tmp/checklist.tmp.$$
+
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
+fi
+
+${MKDIR} ${WRKDIRPREFIX}${CURDIR}
+exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+
+echo "PREFIX= ${PREFIX}"
+
+while [ "$1" ]; do
+ case $1 in
+ \"MySQL\")
+ echo "LIB_DEPENDS+= mysqlclient.6:\${PORTSDIR}/databases/mysql322-client"
+ echo "CONFIGURE_ARGS+=--with-mysql=\${PREFIX}"
+ ;;
+ \"OpenLDAP\")
+ echo "LIB_DEPENDS+= ldap.1:\${PORTSDIR}/net/openldap"
+ echo "LIB_DEPENDS+= lber.1:\${PORTSDIR}/net/openldap"
+ echo "CONFIGURE_ARGS+=--with-ldap=\${PREFIX}"
+ ;;
+ *)
+ echo "Invalid option(s): $*" > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ ;;
+ esac
+ shift
+done