aboutsummaryrefslogtreecommitdiff
path: root/security/gnupg
diff options
context:
space:
mode:
Diffstat (limited to 'security/gnupg')
-rw-r--r--security/gnupg/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 8279a72fa86e..4ac1d71bbdba 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -30,9 +30,10 @@ USE_GMAKE= YES
GNU_CONFIGURE= YES
USE_ICONV= YES
USE_LDCONFIG= YES
+USE_GETTEXT= YES
CONFIGURE_TARGET=# empty
CONFIGURE_ARGS+= --infodir=${PREFIX}/info --mandir=${PREFIX}/man \
- --with-libpth-prefix=${LOCALBASE}/lib/pth
+ --enable-nls --with-libpth-prefix=${LOCALBASE}/lib/pth
MAN1= gpg2.1 gpgsm.1 gpgv2.1 gpg-agent.1 scdaemon.1 watchgnupg.1 \
gpgconf.1 gpg-preset-passphrase.1 gpg-connect-agent.1 \
gpgparsemail.1 symcryptrun.1 gpgsm-gencert.sh.1
@@ -40,24 +41,19 @@ MAN8= addgnupghome.8
INFO= gnupg
OPTIONS= LDAP "LDAP keyserver interface" off \
- NLS "Native Language Support" on \
SCDAEMON "Enable Smartcard daemon (with libusb)" off \
CURL "Use the real curl library (worked around if no)" on
+PLIST_SUB= NLS=""
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= YES
-PLIST_SUB+= NLS=""
-.endif
-
.if defined(WITH_LDAP)
USE_OPENLDAP= YES
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
PLIST_SUB+= LDAP=""
+.if defined(WITHOUT_LDAP)
+BROKEN= Conflict options: WITHOUT_LDAP/WITH_LDAP
+.endif
.else
CONFIGURE_ARGS+=--disable-ldap
PLIST_SUB+= LDAP="@comment "
@@ -67,6 +63,9 @@ PLIST_SUB+= LDAP="@comment "
CONFIGURE_ARGS+=--enable-scdaemon
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
PLIST_SUB+= SCDAEMON=""
+.if defined(WITHOUT_SCDAEMON)
+BROKEN= Conflict options: WITHOUT_SCDAEMON/WITH_SCDAEMON
+.endif
.else
CONFIGURE_ARGS+=--disable-scdaemon
PLIST_SUB+= SCDAEMON="@comment "
@@ -74,6 +73,9 @@ PLIST_SUB+= SCDAEMON="@comment "
.if defined(WITHOUT_CURL)
CONFIGURE_ARGS+=--without-libcurl
+.if defined(WITH_CURL)
+BROKEN= Conflict options: WITHOUT_CURL/WITH_CURL
+.endif
.else
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--with-libcurl=${LOCALBASE}