aboutsummaryrefslogtreecommitdiff
path: root/security/hs-certificate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-certificate/Makefile')
-rw-r--r--security/hs-certificate/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/hs-certificate/Makefile b/security/hs-certificate/Makefile
index 186b599975a5..c732c661bb31 100644
--- a/security/hs-certificate/Makefile
+++ b/security/hs-certificate/Makefile
@@ -7,6 +7,7 @@
PORTNAME= certificate
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -18,12 +19,13 @@ CABAL_SETUP= Setup.hs
USE_CABAL= asn1-data>=0.6.1.3 crypto-pubkey-types>=0.1 mtl pem>=0.1
-OPTIONS= EXECUTABLE "Build the executable" off
+OPTIONS_DEFINE= EXECUTABLE
+
+EXECUTABLE_DESC= Build the executable
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_EXECUTABLE)
+.if ${PORT_OPTIONS:MEXECUTABLE}
CONFIGURE_ARGS+= --flags="executable"
USE_CABAL+= cmdargs text>=0.11 cryptohash cryptocipher>=0.3.0
EXECUTABLE+= certificate