aboutsummaryrefslogtreecommitdiff
path: root/security/hs-tls
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-tls')
-rw-r--r--security/hs-tls/Makefile11
-rw-r--r--security/hs-tls/distinfo4
-rw-r--r--security/hs-tls/pkg-descr7
3 files changed, 10 insertions, 12 deletions
diff --git a/security/hs-tls/Makefile b/security/hs-tls/Makefile
index 6c306f08c5f4..799d80979f81 100644
--- a/security/hs-tls/Makefile
+++ b/security/hs-tls/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= tls
-PORTVERSION= 1.2.8
-PORTREVISION= 1
+PORTVERSION= 1.3.1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,11 +9,9 @@ COMMENT= TLS/SSL protocol native implementation (Server and Client)
LICENSE= BSD3CLAUSE
-USE_CABAL= asn1-encoding asn1-types>=0.2.0 byteable cereal>=0.4 \
- cipher-aes>=0.2 cipher-des cipher-rc4 crypto-cipher-types>=0.0.8 \
- crypto-numbers crypto-pubkey>=0.2.4 crypto-pubkey-types>=0.4 \
- crypto-random>=0.0 cryptohash>=0.6 data-default-class \
- mtl network x509>=1.4.3 x509-store>=1.4.4 x509-validation>=1.5.0
+USE_CABAL= asn1-encoding asn1-types>=0.2.0 async byteable cereal>=0.4 \
+ cryptonite>=0.3 data-default-class memory mtl network \
+ x509>=1.6 x509-store>=1.6 x509-validation>=1.6
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-tls/distinfo b/security/hs-tls/distinfo
index 1c52048f4b9b..be06dfa90070 100644
--- a/security/hs-tls/distinfo
+++ b/security/hs-tls/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/tls-1.2.8.tar.gz) = 0a160cdc57d55cfbb6828eb448b1b6ca5e0626d98536c58d7523662fac34a33a
-SIZE (cabal/tls-1.2.8.tar.gz) = 65498
+SHA256 (cabal/tls-1.3.1.tar.gz) = 747f840677115d077ef548b4da54acb479253ce3cb58ad3a03275fe2b452d5d0
+SIZE (cabal/tls-1.3.1.tar.gz) = 74668
diff --git a/security/hs-tls/pkg-descr b/security/hs-tls/pkg-descr
index b7cd3db8b79c..7b2478c5184d 100644
--- a/security/hs-tls/pkg-descr
+++ b/security/hs-tls/pkg-descr
@@ -1,8 +1,9 @@
Native Haskell TLS and SSL protocol implementation for server and
-client. This provides a high-level implementation of a sensitive
+client. This provides a high-level implementation of a sensitive
security protocol, eliminating a common set of security issues through
the use of the advanced type system, high level constructions and common
-Haskell features. Currently implement the SSL3.0, TLS1.0, TLS1.1 and
-TLS1.2 protocol, with only RSA supported for Key Exchange.
+Haskell features. Currently implement the SSL3.0, TLS1.0, TLS1.1 and
+TLS1.2 protocol, and support RSA and Ephemeral (Elliptic curve and
+regular) Diffie Hellman key exchanges, and many extensions.
WWW: http://github.com/vincenthz/hs-tls