aboutsummaryrefslogtreecommitdiff
path: root/security/krb5-120
diff options
context:
space:
mode:
Diffstat (limited to 'security/krb5-120')
-rw-r--r--security/krb5-120/Makefile6
-rw-r--r--security/krb5-120/files/patch-configure.ac17
-rw-r--r--security/krb5-120/files/patch-util_ss_listen.c14
3 files changed, 35 insertions, 2 deletions
diff --git a/security/krb5-120/Makefile b/security/krb5-120/Makefile
index d2557352ae56..dd175bf24bd6 100644
--- a/security/krb5-120/Makefile
+++ b/security/krb5-120/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= heimdal krb5 krb5-11* krb5-121
CONFLICTS_BUILD= boringssl
KERBEROSV_URL= http://web.mit.edu/kerberos/
-USES= compiler:c++11-lang cpe gmake gettext-runtime \
+USES= autoreconf compiler:c++11-lang cpe gmake gettext-runtime \
gssapi:bootstrap,mit libtool:build localbase \
perl5 pkgconfig ssl
USE_CSTD= gnu99
@@ -39,7 +39,7 @@ CPE_PRODUCT= kerberos
OPTIONS_DEFINE= EXAMPLES NLS KRB5_PDF KRB5_HTML DNS_FOR_REALM LDAP LMDB
OPTIONS_DEFAULT= KRB5_PDF KRB5_HTML READLINE
OPTIONS_RADIO= CMD_LINE_EDITING
-OPTIONS_RADIO_CMD_LINE_EDITING= READLINE LIBEDIT
+OPTIONS_RADIO_CMD_LINE_EDITING= READLINE LIBEDIT LIBEDIT_BASE
CMD_LINE_EDITING_DESC= Command line editing for kadmin and ktutil
KRB5_PDF_DESC= Install krb5 PDF documentation
KRB5_HTML_DESC= Install krb5 HTML documentation
@@ -58,6 +58,8 @@ READLINE_USES= readline
READLINE_CONFIGURE_WITH=readline
LIBEDIT_USES= libedit
LIBEDIT_CONFIGURE_WITH= libedit
+LIBEDIT_BASE_CONFIGURE_WITH= libedit
+LIBEDIT_BASE_DESC= Use libedit in FreeBSD base
.if defined(KRB5_HOME)
PREFIX= ${KRB5_HOME}
diff --git a/security/krb5-120/files/patch-configure.ac b/security/krb5-120/files/patch-configure.ac
new file mode 100644
index 000000000000..abbae0e771b3
--- /dev/null
+++ b/security/krb5-120/files/patch-configure.ac
@@ -0,0 +1,17 @@
+--- configure.ac.orig 2023-08-07 11:38:21.000000000 -0700
++++ configure.ac 2023-08-09 14:49:19.833149000 -0700
+@@ -1356,8 +1356,12 @@
+ AC_DEFINE([HAVE_LIBEDIT], 1, [Define if building with libedit.])
+ AC_MSG_NOTICE([Using libedit for readline support])
+ elif test "x$with_libedit" = xyes; then
+- # We were explicitly asked for libedit and couldn't find it.
+- AC_MSG_ERROR([Could not detect libedit with pkg-config])
++ AC_MSG_NOTICE([Using libedit in FreeBSD base])
++ AC_CHECK_LIB([edit], [main], :,
++ AC_MSG_ERROR([Could not detect libedit]))
++ AC_DEFINE([HAVE_LIBEDIT], 1, [Define if building with libedit.])
++ RL_CFLAGS=-DFreeBSD_BASE_EDITLINE
++ RL_LIBS='-ledit'
+ else
+ AC_MSG_NOTICE([Not using any readline support])
+ fi
diff --git a/security/krb5-120/files/patch-util_ss_listen.c b/security/krb5-120/files/patch-util_ss_listen.c
new file mode 100644
index 000000000000..127784b0e2c0
--- /dev/null
+++ b/security/krb5-120/files/patch-util_ss_listen.c
@@ -0,0 +1,14 @@
+--- util/ss/listen.c.orig 2023-08-07 11:38:21.000000000 -0700
++++ util/ss/listen.c 2023-08-09 13:09:30.816661000 -0700
+@@ -15,7 +15,11 @@
+ #include <sys/param.h>
+
+ #if defined(HAVE_LIBEDIT)
++#if defined(FreeBSD_BASE_EDITLINE)
++#include <edit/readline/readline.h>
++#else
+ #include <editline/readline.h>
++#endif
+ #elif defined(HAVE_READLINE)
+ #include <readline/readline.h>
+ #include <readline/history.h>