aboutsummaryrefslogtreecommitdiff
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile29
1 files changed, 3 insertions, 26 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 5cb410d22eef..33ef60dd7efd 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,8 +7,8 @@
PORTNAME= openssl
PORTVERSION= 1.0.0
-DISTVERSIONSUFFIX= g
-PORTREVISION= 9
+DISTVERSIONSUFFIX= h
+PORTREVISION= 10
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
@@ -16,8 +16,6 @@ MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
MASTER_SITE_SUBDIR= source
DIST_SUBDIR= ${DISTNAME}
-PATCH_SITES= http://sctp.fh-muenster.de/dtls/
-
MAINTAINER= dinoex@FreeBSD.org
COMMENT= SSL and crypto library
@@ -33,10 +31,7 @@ OPTIONS= I386 "Use optimized assembler for 80386" off \
ZLIB "Build with zlib compression" on \
MD2 "Build with MD2 hash (obsolete)" on \
RC5 "Build with RC5 chipher (patented)" off \
- RFC3779 "Build with RFC3779 support" off \
- DTLS_RENEGOTIATION "Build with DTLS Abbr. renegotiations" off \
- DTLS_HEARTBEAT "Build with DTLS Heartbeat Extension" off \
- SCTP "Build with SCTP support" off \
+ RFC3779 "Build with RFC3779 support" off
MAKE_JOBS_UNSAFE= yes
NOPRECIOUSMAKEVARS= Too many _MLINKS for fetch
@@ -1105,24 +1100,6 @@ EXTRACONFIGURE+= enable-rfc3779
EXTRACONFIGURE+= no-rfc3779
.endif
-.if defined(WITH_SCTP)
-EXTRACONFIGURE+= sctp
-.if defined(WITH_DTLS_HEARTBEAT)
-BROKEN= Patches do not merge, please change options
-.endif
-.endif
-
-# order of PATCHFILES is important
-.if defined(WITH_DTLS_RENEGOTIATION) || make(makesum) || defined(FETCH_ALL)
-PATCHFILES+= abbreviated-renegotiation.patch
-.endif
-.if defined(WITH_DTLS_HEARTBEAT) || make(makesum) || defined(FETCH_ALL)
-PATCHFILES+= dtls-heartbeats.patch
-.endif
-.if defined(WITH_SCTP) || make(makesum) || defined(FETCH_ALL)
-PATCHFILES+= dtls-sctp-24.patch
-.endif
-
.if ${OPENSSL_SHLIBVER_BASE} > ${OPENSSL_SHLIBVER}
pre-everything::
@${ECHO_CMD} "#"