aboutsummaryrefslogtreecommitdiff
path: root/security/py-cybox
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-cybox')
-rw-r--r--security/py-cybox/Makefile30
-rw-r--r--security/py-cybox/distinfo2
-rw-r--r--security/py-cybox/pkg-descr3
3 files changed, 35 insertions, 0 deletions
diff --git a/security/py-cybox/Makefile b/security/py-cybox/Makefile
new file mode 100644
index 000000000000..d7a28726c787
--- /dev/null
+++ b/security/py-cybox/Makefile
@@ -0,0 +1,30 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cybox
+PORTVERSION= 2.1.0.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Python library for parsing, manipulating, and generating CybOX content
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=3.1:${PORTSDIR}/devel/py-lxml
+
+USE_PYTHON= 2
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST=yes
+
+PORTDOCS= README.rst
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/py-cybox/distinfo b/security/py-cybox/distinfo
new file mode 100644
index 000000000000..50c9ed3a6735
--- /dev/null
+++ b/security/py-cybox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cybox-2.1.0.0.tar.gz) = 1fed80ce5ecdf14da5295db37e49ee6facbee1d7add2ce738c194334de6945a8
+SIZE (cybox-2.1.0.0.tar.gz) = 859689
diff --git a/security/py-cybox/pkg-descr b/security/py-cybox/pkg-descr
new file mode 100644
index 000000000000..ae64556a501f
--- /dev/null
+++ b/security/py-cybox/pkg-descr
@@ -0,0 +1,3 @@
+A Python library for parsing, manipulating, and generating CybOX content.
+
+WWW: https://github.com/CybOXProject/python-cybox/