aboutsummaryrefslogtreecommitdiff
path: root/security/py-mcrypt
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-mcrypt')
-rw-r--r--security/py-mcrypt/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/py-mcrypt/Makefile b/security/py-mcrypt/Makefile
index 21fe43d8be14..267d83b26d3d 100644
--- a/security/py-mcrypt/Makefile
+++ b/security/py-mcrypt/Makefile
@@ -20,10 +20,15 @@ COMMENT= A comprehensive Python interface to the mcrypt library
LIB_DEPENDS= mcrypt:${PORTSDIR}/security/libmcrypt
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS=yes
+USE_REINPLACE= yes
PYDISTUTILS_BUILDARGS= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
+pre-patch:
+ # put a missed terminating quote
+ ${REINPLACE_CMD} -e '1136s,$$,\\,g' -e '1678s,$$,\\,g' ${WRKSRC}/mcrypt.c
+
do-build:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} build_ext ${PYDISTUTILS_BUILDARGS})