aboutsummaryrefslogtreecommitdiff
path: root/security/ruby-blowfish
diff options
context:
space:
mode:
Diffstat (limited to 'security/ruby-blowfish')
-rw-r--r--security/ruby-blowfish/Makefile10
-rw-r--r--security/ruby-blowfish/distinfo2
-rw-r--r--security/ruby-blowfish/pkg-plist2
3 files changed, 10 insertions, 4 deletions
diff --git a/security/ruby-blowfish/Makefile b/security/ruby-blowfish/Makefile
index c63e2f078a12..102949869bab 100644
--- a/security/ruby-blowfish/Makefile
+++ b/security/ruby-blowfish/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= blowfish
-PORTVERSION= 0.1
+PORTVERSION= 0.2
CATEGORIES= security ruby
-MASTER_SITES= http://ruby.metabolix.de/download/
+MASTER_SITES= http://www.rubylinks.de/download/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
@@ -24,12 +24,16 @@ CONFIGURE_ARGS= --with-openssl-include="${OPENSSLBASE}/include/openssl" \
--with-openssl-lib="${OPENSSLBASE}/lib"
INSTALL_TARGET= site-install
+DOCS_EN= ChangeLog README TODO
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/testbf.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/security/ruby-blowfish/distinfo b/security/ruby-blowfish/distinfo
index 621f89689a85..ab6d1e765823 100644
--- a/security/ruby-blowfish/distinfo
+++ b/security/ruby-blowfish/distinfo
@@ -1 +1 @@
-MD5 (ruby/ruby-blowfish-0.1.tar.gz) = 3f8eb0b9ef35b28d21a9b71163ddd30d
+MD5 (ruby/ruby-blowfish-0.2.tar.gz) = 70e48a279ed70071a5d597243a13959b
diff --git a/security/ruby-blowfish/pkg-plist b/security/ruby-blowfish/pkg-plist
index 9cfa5ca155cd..d215634a9cbe 100644
--- a/security/ruby-blowfish/pkg-plist
+++ b/security/ruby-blowfish/pkg-plist
@@ -1,5 +1,7 @@
%%RUBY_SITEARCHLIBDIR%%/Blowfish.so
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/blowfish/testbf.rb
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/blowfish
+%%PORTDOCS%%%%RUBY_DOCDIR%%/blowfish/ChangeLog
%%PORTDOCS%%%%RUBY_DOCDIR%%/blowfish/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/blowfish/TODO
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/blowfish