aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse
diff options
context:
space:
mode:
Diffstat (limited to 'security/seahorse')
-rw-r--r--security/seahorse/Makefile8
-rw-r--r--security/seahorse/distinfo6
-rw-r--r--security/seahorse/files/patch-daemon_seahorse-hkp-server.c13
-rw-r--r--security/seahorse/files/patch-pgp_seahorse-gpgme-source.c10
-rw-r--r--security/seahorse/files/patch-ssh_seahorse-ssh-operation.c19
-rw-r--r--security/seahorse/pkg-plist9
6 files changed, 15 insertions, 50 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index ff70b71e0baf..2f6731c5be56 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -3,12 +3,11 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse/Makefile,v 1.88 2009/10/18 02:38:21 avl Exp $
+# $MCom: ports/security/seahorse/Makefile,v 1.96 2010/04/27 22:04:55 kwm Exp $
#
PORTNAME= seahorse
-PORTVERSION= 2.28.1
-PORTREVISION= 2
+PORTVERSION= 2.30.1
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -34,9 +33,10 @@ INSTALLS_OMF= yes
INSTALLS_ICONS= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-introspection=no
GCONF_SCHEMAS= seahorse.schemas
-MAN1= seahorse-daemon.1
+MAN1= seahorse.1 seahorse-daemon.1
OPTIONS= LDAP "Enable LDAP support" on \
NOTIFY "Enable libnotify support" on \
diff --git a/security/seahorse/distinfo b/security/seahorse/distinfo
index ee99c6c64910..8134344b0bb2 100644
--- a/security/seahorse/distinfo
+++ b/security/seahorse/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/seahorse-2.28.1.tar.bz2) = c49d4d9bcfe7620081df517ab939f67b
-SHA256 (gnome2/seahorse-2.28.1.tar.bz2) = 67a1ae5eaceca6306a6a740c8753c5a6c4b511cfbf8a8031a78ae61297ced0a0
-SIZE (gnome2/seahorse-2.28.1.tar.bz2) = 2397687
+MD5 (gnome2/seahorse-2.30.1.tar.bz2) = b332279b34acca952807e31534fec592
+SHA256 (gnome2/seahorse-2.30.1.tar.bz2) = 1b97064ee91f87494040313a0a2fe813473ec4dba15b5781245080e8fea8e7c3
+SIZE (gnome2/seahorse-2.30.1.tar.bz2) = 2422214
diff --git a/security/seahorse/files/patch-daemon_seahorse-hkp-server.c b/security/seahorse/files/patch-daemon_seahorse-hkp-server.c
deleted file mode 100644
index 1880aad325a3..000000000000
--- a/security/seahorse/files/patch-daemon_seahorse-hkp-server.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- daemon/seahorse-hkp-server.c.orig 2009-08-01 15:25:02.000000000 -0400
-+++ daemon/seahorse-hkp-server.c 2009-08-01 15:23:27.000000000 -0400
-@@ -467,7 +467,9 @@ seahorse_hkp_server_start(GError **err)
- /* Initialize GPGME context */
- if (gpgme_ctx == NULL) {
- gpgme_protocol_t proto = GPGME_PROTOCOL_OpenPGP;
-- gpgme_error_t err = gpgme_engine_check_version (proto);
-+ gpgme_error_t err;
-+ gpgme_check_version (NULL);
-+ err = gpgme_engine_check_version (proto);
- g_return_val_if_fail (GPG_IS_OK (err), FALSE);
-
- err = gpgme_new (&gpgme_ctx);
diff --git a/security/seahorse/files/patch-pgp_seahorse-gpgme-source.c b/security/seahorse/files/patch-pgp_seahorse-gpgme-source.c
deleted file mode 100644
index b036a81571df..000000000000
--- a/security/seahorse/files/patch-pgp_seahorse-gpgme-source.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- pgp/seahorse-gpgme-source.c.orig 2009-08-01 15:24:28.000000000 -0400
-+++ pgp/seahorse-gpgme-source.c 2009-08-01 15:23:24.000000000 -0400
-@@ -139,6 +139,7 @@ init_gpgme (gpgme_ctx_t *ctx)
- gpgme_protocol_t proto = GPGME_PROTOCOL_OpenPGP;
- gpgme_error_t err;
-
-+ gpgme_check_version (NULL);
- err = gpgme_engine_check_version (proto);
- g_return_val_if_fail (GPG_IS_OK (err), err);
-
diff --git a/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c b/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c
deleted file mode 100644
index 1c7acece0685..000000000000
--- a/security/seahorse/files/patch-ssh_seahorse-ssh-operation.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- ssh/seahorse-ssh-operation.c.orig 2009-04-12 10:29:33.000000000 -0400
-+++ ssh/seahorse-ssh-operation.c 2009-04-19 20:44:50.000000000 -0400
-@@ -281,11 +281,14 @@ askpass_handler (GIOChannel *source, GIO
- const gchar *result = NULL;
-
- if (condition & G_IO_IN) {
-+ GIOStatus status;
-
- /* Read 1 line from the io channel, including newline character */
-- g_io_channel_read_line (source, &string, &length, NULL, &err);
-+ status = g_io_channel_read_line (source, &string, &length, NULL, &err);
-
-- if (err != NULL) {
-+ if (status == G_IO_STATUS_EOF) {
-+ ret = FALSE;
-+ } else if (err != NULL) {
- g_critical ("couldn't read from seahorse-ssh-askpass: %s", err->message);
- g_clear_error (&err);
- ret = FALSE;
diff --git a/security/seahorse/pkg-plist b/security/seahorse/pkg-plist
index a15a34c04cc4..453aae477c26 100644
--- a/security/seahorse/pkg-plist
+++ b/security/seahorse/pkg-plist
@@ -1,6 +1,5 @@
bin/seahorse
bin/seahorse-daemon
-etc/xdg/autostart/seahorse-daemon.desktop
include/libcryptui/cryptui-key-chooser.h
include/libcryptui/cryptui-key-combo.h
include/libcryptui/cryptui-key-list.h
@@ -120,6 +119,7 @@ share/icons/hicolor/48x48/apps/seahorse-preferences.png
share/icons/hicolor/48x48/apps/seahorse.png
share/locale/ar/LC_MESSAGES/seahorse.mo
share/locale/as/LC_MESSAGES/seahorse.mo
+share/locale/ast/LC_MESSAGES/seahorse.mo
share/locale/az/LC_MESSAGES/seahorse.mo
share/locale/be@latin/LC_MESSAGES/seahorse.mo
share/locale/bg/LC_MESSAGES/seahorse.mo
@@ -136,6 +136,7 @@ share/locale/dz/LC_MESSAGES/seahorse.mo
share/locale/el/LC_MESSAGES/seahorse.mo
share/locale/en_CA/LC_MESSAGES/seahorse.mo
share/locale/en_GB/LC_MESSAGES/seahorse.mo
+share/locale/en@shaw/LC_MESSAGES/seahorse.mo
share/locale/es/LC_MESSAGES/seahorse.mo
share/locale/et/LC_MESSAGES/seahorse.mo
share/locale/eu/LC_MESSAGES/seahorse.mo
@@ -148,6 +149,7 @@ share/locale/he/LC_MESSAGES/seahorse.mo
share/locale/hi/LC_MESSAGES/seahorse.mo
share/locale/hr/LC_MESSAGES/seahorse.mo
share/locale/hu/LC_MESSAGES/seahorse.mo
+share/locale/id/LC_MESSAGES/seahorse.mo
share/locale/it/LC_MESSAGES/seahorse.mo
share/locale/ja/LC_MESSAGES/seahorse.mo
share/locale/kn/LC_MESSAGES/seahorse.mo
@@ -170,6 +172,7 @@ share/locale/pa/LC_MESSAGES/seahorse.mo
share/locale/pl/LC_MESSAGES/seahorse.mo
share/locale/pt/LC_MESSAGES/seahorse.mo
share/locale/pt_BR/LC_MESSAGES/seahorse.mo
+share/locale/ro/LC_MESSAGES/seahorse.mo
share/locale/ru/LC_MESSAGES/seahorse.mo
share/locale/rw/LC_MESSAGES/seahorse.mo
share/locale/si/LC_MESSAGES/seahorse.mo
@@ -315,6 +318,8 @@ share/pixmaps/seahorse/scalable/seahorse-sign.svg
@dirrmtry share/locale/mai
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
@dirrmtry share/locale/ca@valencia/LC_MESSAGES
@@ -323,5 +328,7 @@ share/pixmaps/seahorse/scalable/seahorse-sign.svg
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as