aboutsummaryrefslogtreecommitdiff
path: root/security/snoopy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/snoopy/Makefile')
-rw-r--r--security/snoopy/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/security/snoopy/Makefile b/security/snoopy/Makefile
index 9f77d7022da3..872eaaedf01a 100644
--- a/security/snoopy/Makefile
+++ b/security/snoopy/Makefile
@@ -30,7 +30,17 @@ USE_GITHUB= yes
SHEBANG_GLOB= *.sh
post-patch:
+ @${REINPLACE_CMD} -e 's| -Wall -Werror||' ${WRKSRC}/configure.ac ${WRKSRC}/build/Makefile.am.common
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/README.md
+ @${REINPLACE_CMD} -e '/#define.*_XOPEN_SOURCE/d' \
+ ${WRKSRC}/src/configfile.c \
+ ${WRKSRC}/src/datasource/sid.c \
+ ${WRKSRC}/src/datasource/snoopy_version.c \
+ ${WRKSRC}/src/snoopy.h \
+ ${WRKSRC}/tests/bin/snoopy-test-threads.c \
+ ${WRKSRC}/src/tsrm.c
+ @${REINPLACE_CMD} -e '/features.h/d' ${WRKSRC}/configure.ac ${WRKSRC}/src/output/socketoutput.c ${WRKSRC}/src/snoopy.h
+ @${REINPLACE_CMD} -e 's|#include <wait.h>|#include <sys/wait.h>|' ${WRKSRC}/tests/bin/snoopy-test-exec-in-threads.c ${WRKSRC}/tests/bin/snoopy-test-threads.c
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/