aboutsummaryrefslogtreecommitdiff
path: root/security/snort/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/snort/Makefile')
-rw-r--r--security/snort/Makefile21
1 files changed, 3 insertions, 18 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 7e64b373e6b7..1708ba48aae1 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -3,6 +3,7 @@
PORTNAME= snort
PORTVERSION= 2.9.8.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://snort.org/downloads/snort/ \
http://www.talosintel.com/downloads/ \
@@ -17,7 +18,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
- libnet.so:${PORTSDIR}/net/libnet
+ libdnet.so:${PORTSDIR}/net/libdnet
BUILD_DEPENDS= daq>=2.0.0:${PORTSDIR}/net/daq
RUN_DEPENDS= daq>=2.0.0:${PORTSDIR}/net/daq
@@ -88,24 +89,10 @@ DOCS= RELEASE.NOTES doc/AUTHORS doc/BUGS doc/CREDITS \
doc/README* doc/USAGE doc/*.pdf
PREPROC_RULES= decoder.rules preprocessor.rules sensitive-data.rules
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-.if exists(${LIBNET_CONFIG})
-LIBNET_CFLAGS!= ${LIBNET_CONFIG} --cflags
-LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
-.else
-LIBNET_CFLAGS= -I${LOCALBASE}/include/libnet11
-LIBNET_LIBS= -L${LOCALBASE}/lib/libnet11 -lnet
-.endif
-
-LIBNET_INCDIR= ${LIBNET_CFLAGS:M-I*:S/-I//}
-LIBNET_LIBDIR= ${LIBNET_LIBS:M-L*:S/-L//}
-
CFLAGS+= -fstack-protector
CONFIGURE_ARGS+=--enable-reload \
--enable-mpls --enable-targetbased \
- --enable-reload-error-restart \
- --with-dnet-includes=${LIBNET_INCDIR} \
- --with-dnet-libraries=${LIBNET_LIBDIR}
+ --enable-reload-error-restart
post-patch:
@${REINPLACE_CMD} "s,/etc/snort.conf,${ETCDIR}/snort.conf," \
@@ -116,8 +103,6 @@ post-patch:
-e '/^# include .PREPROC_RULE/s/# include/include/' \
${WRKSRC}/etc/snort.conf
- @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|g' ${WRKSRC}/configure
-
# IPv6 is no longer a ./configure option!
.if ! ${PORT_OPTIONS:MIPV6}
@${REINPLACE_CMD} -e '/normalize_ip6/s/^preprocessor/#preprocessor/' \