aboutsummaryrefslogtreecommitdiff
path: root/security/tlswrap
diff options
context:
space:
mode:
Diffstat (limited to 'security/tlswrap')
-rw-r--r--security/tlswrap/Makefile42
-rw-r--r--security/tlswrap/distinfo2
-rw-r--r--security/tlswrap/pkg-descr4
3 files changed, 48 insertions, 0 deletions
diff --git a/security/tlswrap/Makefile b/security/tlswrap/Makefile
new file mode 100644
index 000000000000..f3d8713a7c75
--- /dev/null
+++ b/security/tlswrap/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: tlswrap
+# Date created: 25 July 2005
+# Whom: Daniel O'Connor <darius@dons.net.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tlswrap
+PORTVERSION= 1.0.2
+CATEGORIES= security
+MASTER_SITES= http://tlswrap.sunsite.dk/
+DISTNAME= ${PORTNAME}-1.02
+
+MAINTAINER= darius@dons.net.au
+COMMENT= An FTP proxy that wraps data and control with TLS/SSL
+
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/tlswrap
+PORTDOCS= README
+
+.include <bsd.port.pre.mk>
+
+post-configure:
+.if ( ${OSVERSION} < 500000 )
+ @${REINPLACE_CMD} -E 's,#define socklen_t size_t,,g' \
+ ${WRKSRC}/conf.h
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E 's,^(CC|CFLAGS|LDFLAGS).*=,\1?=,g' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/tlswrap/distinfo b/security/tlswrap/distinfo
new file mode 100644
index 000000000000..f148de649740
--- /dev/null
+++ b/security/tlswrap/distinfo
@@ -0,0 +1,2 @@
+MD5 (tlswrap-1.02.tar.gz) = fa9e503a861a7519a8f485bad77e2cc7
+SIZE (tlswrap-1.02.tar.gz) = 137602
diff --git a/security/tlswrap/pkg-descr b/security/tlswrap/pkg-descr
new file mode 100644
index 000000000000..ba430d28638e
--- /dev/null
+++ b/security/tlswrap/pkg-descr
@@ -0,0 +1,4 @@
+TLSWrap is a TLS/SSL FTP wrapper/proxy for UNIX and Windows, allowing you to
+use your favourite FTP client with any TLS/SSL-enabled FTP server.
+
+WWW: http://tlswrap.sunsite.dk/